aboutsummaryrefslogtreecommitdiff
path: root/python/python3-plexapi/python3-plexapi.SlackBuild
diff options
context:
space:
mode:
authorPouria Rezaei <Pouria.rz@outlook.com>2024-11-22 22:39:50 +0330
committerWilly Sudiarto Raharjo <willysr@slackbuilds.org>2024-11-23 09:23:47 +0700
commit39a30928778104841eeac11dbb060f93fe2fc7fe (patch)
treef2d9754c3a797dd43fd976d792743d6edfcc00c0 /python/python3-plexapi/python3-plexapi.SlackBuild
parent915e4108ef565e958c0fc8be0ce15fd4002dbf78 (diff)
python/python3-plexapi: Updated to 4.16.0.
Signed-off-by: Pouria Rezaei <Pouria.rz@outlook.com> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python/python3-plexapi/python3-plexapi.SlackBuild')
-rw-r--r--python/python3-plexapi/python3-plexapi.SlackBuild10
1 files changed, 6 insertions, 4 deletions
diff --git a/python/python3-plexapi/python3-plexapi.SlackBuild b/python/python3-plexapi/python3-plexapi.SlackBuild
index abefd851e4..17bd2a3b70 100644
--- a/python/python3-plexapi/python3-plexapi.SlackBuild
+++ b/python/python3-plexapi/python3-plexapi.SlackBuild
@@ -26,8 +26,8 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=python3-plexapi
-VERSION=${VERSION:-4.15.16}
-SRCNAM=PlexAPI
+VERSION=${VERSION:-4.16.0}
+SRCNAM=plexapi
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -67,9 +67,11 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-sed -i -e "s~.*scripts=glob.glob(\"Scripts/\*.py\"),~~" setup.py
+PYVER=$(python3 -c 'import sys; print("%d.%d" % sys.version_info[:2])')
+export PYTHONPATH=/opt/python$PYVER/site-packages/
-python3 setup.py install --root=$PKG
+python3 -m build --wheel --no-isolation
+python3 -m installer --destdir="$PKG" dist/*.whl
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" \
| grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true