aboutsummaryrefslogtreecommitdiff
path: root/python/python3-nltk/python3-nltk.SlackBuild
diff options
context:
space:
mode:
authorArTourter <artourter@gmail.com>2023-04-09 22:24:41 +0100
committerWilly Sudiarto Raharjo <willysr@slackbuilds.org>2023-04-15 07:15:32 +0700
commitd88d85304786b092d6763f8142a74310388e8141 (patch)
treecc624e0cdf6b7eb97d48e1c5bbb1cd665a31fb23 /python/python3-nltk/python3-nltk.SlackBuild
parent9634f2a876f188f5e1868e46229edab7dd79fb7f (diff)
python/python3-nltk: Updated for version 3.8.1.
- move build system to python3-build python3-installed and wheel - add optional runtime dependency in python3-numpy note in README - correct mention of python3-regex (instead of 'regex') in README Signed-off-by: ArTourter <artourter@gmail.com> Signed-off-by: Andrew Clemons <andrew.clemons@gmail.com> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python/python3-nltk/python3-nltk.SlackBuild')
-rw-r--r--python/python3-nltk/python3-nltk.SlackBuild7
1 files changed, 4 insertions, 3 deletions
diff --git a/python/python3-nltk/python3-nltk.SlackBuild b/python/python3-nltk/python3-nltk.SlackBuild
index 7b5f69af3c..0654412bba 100644
--- a/python/python3-nltk/python3-nltk.SlackBuild
+++ b/python/python3-nltk/python3-nltk.SlackBuild
@@ -3,7 +3,7 @@
# Slackware build script for python3-nltk.
#
# Copyright 2009-2011 Marco Bonetti <sid77@slackware.it>
-# Copyright 2015-2022 Gregory J. L. Tourte <artourter@gmail.com>
+# Copyright 2015-2023 Gregory J. L. Tourte <artourter@gmail.com>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -26,7 +26,7 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=python3-nltk
-VERSION=${VERSION:-3.8}
+VERSION=${VERSION:-3.8.1}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -72,7 +72,8 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
-exec chmod 644 {} \;
-python3 setup.py install --root=$PKG
+python3 -m build --no-isolation
+python3 -m installer -d "$PKG" dist/*.whl
find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true