aboutsummaryrefslogtreecommitdiff
path: root/python/python3-itsdangerous/python3-itsdangerous.SlackBuild
diff options
context:
space:
mode:
authorfourtysixandtwo <fourtysixandtwo@sliderr.net>2024-11-28 01:54:25 -0700
committerWilly Sudiarto Raharjo <willysr@slackbuilds.org>2024-11-30 15:53:21 +0700
commit96e1e83d80d7d5b5427167e5edb2e8b522ff5d72 (patch)
tree31c31ff9e4df535b19b2c3af8fe235d2a4fa9b31 /python/python3-itsdangerous/python3-itsdangerous.SlackBuild
parent94c7cd877b1253d4d4d4b30130aa0880e7b8ef06 (diff)
python/python3-itsdangerous: Updated for version 2.2.0, new maintainer.
Tried to contact maintainer but no reply, and no updates in over a year Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python/python3-itsdangerous/python3-itsdangerous.SlackBuild')
-rw-r--r--python/python3-itsdangerous/python3-itsdangerous.SlackBuild38
1 files changed, 11 insertions, 27 deletions
diff --git a/python/python3-itsdangerous/python3-itsdangerous.SlackBuild b/python/python3-itsdangerous/python3-itsdangerous.SlackBuild
index 605f59374d..a2da966efe 100644
--- a/python/python3-itsdangerous/python3-itsdangerous.SlackBuild
+++ b/python/python3-itsdangerous/python3-itsdangerous.SlackBuild
@@ -2,6 +2,7 @@
# Slackware build script for python3-itsdangerous
+# Copyright 2024 fourtysixandtwo <fourtysixandtwo@sliderr.net>
# Copyright 2019 MDrights
# All rights reserved.
#
@@ -27,8 +28,8 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=python3-itsdangerous
-PROGNAM=itsdangerous
-VERSION=${VERSION:-2.1.2}
+SRCNAM=itsdangerous
+VERSION=${VERSION:-2.2.0}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -41,9 +42,6 @@ if [ -z "$ARCH" ]; then
esac
fi
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
@@ -53,43 +51,29 @@ TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
-if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-O2 -march=i586 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
set -e
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
-rm -rf $PROGNAM-$VERSION
-tar xvf $CWD/$PROGNAM-$VERSION.tar.gz
-cd $PROGNAM-$VERSION
+rm -rf $SRCNAM-$VERSION
+tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
+cd $SRCNAM-$VERSION
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
+ -o -perm 511 \) -exec chmod 755 {} \+ -o \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \+
-# build with python3
-python3 setup.py install --root=$PKG
+python3 -m flit_core.wheel
+python3 -m installer -d "$PKG" dist/*.whl
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a README.rst CHANGES.rst LICENSE.rst PKG-INFO docs/*.rst $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a README.md CHANGES.rst LICENSE.txt PKG-INFO docs/*.rst $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install