aboutsummaryrefslogtreecommitdiff
path: root/python/python3-httpx
diff options
context:
space:
mode:
authorfourtysixandtwo <fourtysixandtwo@sliderr.net>2024-09-09 11:34:08 -0600
committerWilly Sudiarto Raharjo <willysr@slackbuilds.org>2024-09-14 23:36:58 +0700
commit6f39dd73f7705b9388f3075783ab3758854657d1 (patch)
tree7c1055ffba0e202f5f0af9c612c0ac431aa2dd77 /python/python3-httpx
parentd813d2a806f5cfea350657fda25c97a0d56ed8d6 (diff)
python/python3-httpx: Fix for new hatchling.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python/python3-httpx')
-rw-r--r--python/python3-httpx/python3-httpx.SlackBuild3
1 files changed, 3 insertions, 0 deletions
diff --git a/python/python3-httpx/python3-httpx.SlackBuild b/python/python3-httpx/python3-httpx.SlackBuild
index 824b559f9525c..9c54101cb34e8 100644
--- a/python/python3-httpx/python3-httpx.SlackBuild
+++ b/python/python3-httpx/python3-httpx.SlackBuild
@@ -66,6 +66,9 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \+
+PYVER=$(python3 -c 'import sys; print("%d.%d" % sys.version_info[:2])')
+export PYTHONPATH=/opt/python$PYVER/site-packages
+
#remove upper version requirement from pyproject.toml and PKG-INFO
/usr/bin/sed -i 's/,<[0-9].*\",$/\",/' pyproject.toml
/usr/bin/sed -i 's/<[0-9].*,//' PKG-INFO