aboutsummaryrefslogtreecommitdiff
path: root/python/python3-httpcore/python3-httpcore.SlackBuild
diff options
context:
space:
mode:
authorfourtysixandtwo <fourtysixandtwo@sliderr.net>2023-09-17 17:38:24 -0600
committerWilly Sudiarto Raharjo <willysr@slackbuilds.org>2023-09-23 11:33:50 +0700
commit177983969bbdf74bd193b57e254e02da00cf16af (patch)
treefb8e033eb7bea5dee66373f9ffafeca38c3d6ea8 /python/python3-httpcore/python3-httpcore.SlackBuild
parentcf8ce466b548a96979443e5b6f09557f6eee6b1f (diff)
python/python3-httpcore: Updated for version 0.18.0.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python/python3-httpcore/python3-httpcore.SlackBuild')
-rw-r--r--python/python3-httpcore/python3-httpcore.SlackBuild12
1 files changed, 5 insertions, 7 deletions
diff --git a/python/python3-httpcore/python3-httpcore.SlackBuild b/python/python3-httpcore/python3-httpcore.SlackBuild
index 5f918bb835..c3b4445ed0 100644
--- a/python/python3-httpcore/python3-httpcore.SlackBuild
+++ b/python/python3-httpcore/python3-httpcore.SlackBuild
@@ -23,12 +23,13 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
# 20220630 46and2: Updated version.
+# 20230917 46and2: Updated version, change build process
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=python3-httpcore
SRCNAM=${PRGNAM#python3-*}
-VERSION=${VERSION:-0.17.3}
+VERSION=${VERSION:-0.18.0}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -82,17 +83,14 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \+
-#remove upper version requirement from setup.py and httpcore.egg-info/requires.txt
-/usr/bin/sed -i 's/,<[0-9].*\",$/\",/' setup.py
-/usr/bin/sed -i 's/<[0-9].*,//' httpcore.egg-info/requires.txt
-
-python3 setup.py install --root=$PKG
+python3 -m build --no-isolation
+python3 -m installer -d "$PKG" dist/*.whl
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a LICENSE.md README.md $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a CHANGELOG.md LICENSE.md README.md $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install