aboutsummaryrefslogtreecommitdiff
path: root/python/python3-glad/python3-glad.SlackBuild
diff options
context:
space:
mode:
authorChristoph Willing <chris.willing@linux.com>2024-10-29 10:38:06 +1100
committerWilly Sudiarto Raharjo <willysr@slackbuilds.org>2024-11-02 19:28:48 +0700
commit99c6c2b96c52f667efc4a7080c4c581631e0ed81 (patch)
tree1537a0e715328fc3cb1085ec12a0ddf01c658d00 /python/python3-glad/python3-glad.SlackBuild
parenta75ed8d97fd6dfc25337836fb72e6fbcd926a201 (diff)
python/python3-glad: Updated for version 2.0.8
Signed-off-by: Christoph Willing <chris.willing@linux.com> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python/python3-glad/python3-glad.SlackBuild')
-rw-r--r--python/python3-glad/python3-glad.SlackBuild10
1 files changed, 7 insertions, 3 deletions
diff --git a/python/python3-glad/python3-glad.SlackBuild b/python/python3-glad/python3-glad.SlackBuild
index c6767c5529..396bd98656 100644
--- a/python/python3-glad/python3-glad.SlackBuild
+++ b/python/python3-glad/python3-glad.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for python3-glad
-# Copyright 2023 Christoph Willing Brisbane, Australia
+# Copyright 2023,2024 Christoph Willing Sydney, Australia
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -26,7 +26,7 @@ cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=python3-glad
SRCNAM=glad
-VERSION=${VERSION:-2.0.4}
+VERSION=${VERSION:-2.0.8}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -63,7 +63,11 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python3 setup.py install --root=$PKG
+PYVER=$(python3 -c 'import sys; print("%d.%d" % sys.version_info[:2])')
+export PYTHONPATH=/opt/python$PYVER/site-packages
+
+python3 -m build --no-isolation
+python3 -m installer -d "$PKG" dist/*.whl
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true