aboutsummaryrefslogtreecommitdiff
path: root/python/python3-blinker
diff options
context:
space:
mode:
authorfourtysixandtwo <fourtysixandtwo@sliderr.net>2023-09-04 06:19:30 -0600
committerWilly Sudiarto Raharjo <willysr@slackbuilds.org>2023-09-09 10:14:15 +0700
commit4094878343f0c78e8f16dddddf4510f76ad664e5 (patch)
tree17ac7347482cb2e20c8835051a9fb9d9c6da59b9 /python/python3-blinker
parentc657016ea13453630904e777bfa27c450ea5ffd1 (diff)
python/python3-blinker: Updated for version 1.6.2.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python/python3-blinker')
-rw-r--r--python/python3-blinker/python3-blinker.SlackBuild24
-rw-r--r--python/python3-blinker/python3-blinker.info8
2 files changed, 18 insertions, 14 deletions
diff --git a/python/python3-blinker/python3-blinker.SlackBuild b/python/python3-blinker/python3-blinker.SlackBuild
index 55daaad2fd1e6..6df717e822c65 100644
--- a/python/python3-blinker/python3-blinker.SlackBuild
+++ b/python/python3-blinker/python3-blinker.SlackBuild
@@ -2,15 +2,16 @@
# Slackware build script for python3-blinker
-# Copyright 2022 fourtysixandtwo <fourtysixandtwo@sliderr.net>
+# Copyright 2022-23 fourtysixandtwo <fourtysixandtwo@sliderr.net>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
# permitted provided that the following conditions are met:
+#
# 1. Redistributions of this script must retain the above copyright
# notice, this list of conditions and the following disclaimer.
#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ``AS IS'' AND ANY EXPRESS OR IMPLIED
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
@@ -20,15 +21,15 @@
# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-#
# 20220512 46and2: Shorten DOWNLOAD url, added python3.
+# 20230904 46and2: build process changed, uses python-setuptools-opt
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=python3-blinker
SRCNAM=${PRGNAM#python3-*}
-VERSION=${VERSION:-1.5}
+VERSION=${VERSION:-1.6.2}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -41,9 +42,6 @@ if [ -z "$ARCH" ]; then
esac
fi
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
@@ -62,6 +60,9 @@ elif [ "$ARCH" = "i686" ]; then
elif [ "$ARCH" = "x86_64" ]; then
SLKCFLAGS="-O2 -fPIC"
LIBDIRSUFFIX="64"
+elif [ "$ARCH" = "aarch64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
else
SLKCFLAGS="-O2"
LIBDIRSUFFIX=""
@@ -78,11 +79,14 @@ cd $SRCNAM-$VERSION
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
+ -o -perm 511 \) -exec chmod 755 {} \+ -o \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \+
+
+export PYTHONPATH=/opt/python3.9/site-packages/
-python3 setup.py install --root=$PKG
+python3 -m build --no-isolation
+python3 -m installer -d "$PKG" dist/*.whl
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
diff --git a/python/python3-blinker/python3-blinker.info b/python/python3-blinker/python3-blinker.info
index 2b3d140e071cf..8852be23a5d8f 100644
--- a/python/python3-blinker/python3-blinker.info
+++ b/python/python3-blinker/python3-blinker.info
@@ -1,10 +1,10 @@
PRGNAM="python3-blinker"
-VERSION="1.5"
+VERSION="1.6.2"
HOMEPAGE="https://pypi.python.org/pypi/blinker/"
-DOWNLOAD="https://files.pythonhosted.org/packages/source/b/blinker/blinker-1.5.tar.gz"
-MD5SUM="e1c3eec8e52210f69ef59d299c6cca07"
+DOWNLOAD="https://files.pythonhosted.org/packages/source/b/blinker/blinker-1.6.2.tar.gz"
+MD5SUM="1c7375d100a67ba368d9cde0ab2d8cfa"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
-REQUIRES=""
+REQUIRES="python3-setuptools-opt"
MAINTAINER="fourtysixandtwo"
EMAIL="fourtysixandtwo@sliderr.net"