aboutsummaryrefslogtreecommitdiff
path: root/python/python3-async-timeout
diff options
context:
space:
mode:
authorIsaac Yu <isaacyu1@isaacyu1.com>2023-05-18 00:56:34 +0100
committerWilly Sudiarto Raharjo <willysr@slackbuilds.org>2023-05-20 11:17:07 +0700
commit266340a67730d4f575e1353cc4cc2656b0119b55 (patch)
tree26fecdedc2032949318c89847e7b046e472a1c0d /python/python3-async-timeout
parent2ec8b42fe4968fe6f3a578159decea103ce98d76 (diff)
python/python3-async-timeout: Added (asyncio-compatible timeout)
Signed-off-by: bedlam <dave@slackbuilds.org> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python/python3-async-timeout')
-rw-r--r--python/python3-async-timeout/README1
-rw-r--r--python/python3-async-timeout/python3-async-timeout.SlackBuild94
-rw-r--r--python/python3-async-timeout/python3-async-timeout.info10
-rw-r--r--python/python3-async-timeout/slack-desc19
4 files changed, 124 insertions, 0 deletions
diff --git a/python/python3-async-timeout/README b/python/python3-async-timeout/README
new file mode 100644
index 000000000000..8d91b81b5c7c
--- /dev/null
+++ b/python/python3-async-timeout/README
@@ -0,0 +1 @@
+async-timeout is an asyncio-compatible timeout context manager.
diff --git a/python/python3-async-timeout/python3-async-timeout.SlackBuild b/python/python3-async-timeout/python3-async-timeout.SlackBuild
new file mode 100644
index 000000000000..b17ea45527c2
--- /dev/null
+++ b/python/python3-async-timeout/python3-async-timeout.SlackBuild
@@ -0,0 +1,94 @@
+#!/bin/bash
+
+# Slackware build script for python3-async-timeout
+
+# Copyright 2019-2023 Isaac Yu <isaacyu1@isaacyu1.com>
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+cd $(dirname $0) ; CWD=$(pwd)
+
+PRGNAM=python3-async-timeout
+VERSION=${VERSION:-4.0.2}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
+
+SRCNAM=async-timeout
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $SRCNAM-$VERSION
+tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
+cd $SRCNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python3 setup.py install --root=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a CHANGES.rst README.rst LICENSE $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/python/python3-async-timeout/python3-async-timeout.info b/python/python3-async-timeout/python3-async-timeout.info
new file mode 100644
index 000000000000..ebb5efa53578
--- /dev/null
+++ b/python/python3-async-timeout/python3-async-timeout.info
@@ -0,0 +1,10 @@
+PRGNAM="python3-async-timeout"
+VERSION="4.0.2"
+HOMEPAGE="https://github.com/aio-libs/async-timeout"
+DOWNLOAD="https://github.com/aio-libs/async-timeout/releases/download/v4.0.2/async-timeout-4.0.2.tar.gz"
+MD5SUM="10571272b2e0fab839ec23f8293bf482"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="typing-extensions"
+MAINTAINER="Isaac Yu"
+EMAIL="isaacyu1@isaacyu1.com"
diff --git a/python/python3-async-timeout/slack-desc b/python/python3-async-timeout/slack-desc
new file mode 100644
index 000000000000..d2a4a33a89f5
--- /dev/null
+++ b/python/python3-async-timeout/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+python3-async-timeout: python3-async-timeout (asyncio-compatible timeout class)
+python3-async-timeout:
+python3-async-timeout: async-timeout is an asyncio-compatible timeout context manager.
+python3-async-timeout:
+python3-async-timeout: https://github.com/aio-libs/async-timeout/
+python3-async-timeout:
+python3-async-timeout:
+python3-async-timeout:
+python3-async-timeout:
+python3-async-timeout:
+python3-async-timeout: