aboutsummaryrefslogtreecommitdiff
path: root/python/python3-argcomplete/python3-argcomplete.SlackBuild
diff options
context:
space:
mode:
authorVijay Marcel <vijaymarcel@outlook.com>2024-02-16 21:54:31 +0700
committerWilly Sudiarto Raharjo <willysr@slackbuilds.org>2024-02-16 21:59:35 +0700
commit8b0560dd4bb6ab10b696878a8312f8019948d354 (patch)
tree450a5a728f6ebab7e32d1ab5c7f30936a5cea56a /python/python3-argcomplete/python3-argcomplete.SlackBuild
parent7bb10a46ed800290b8ee9032ac631ebf91597fcb (diff)
python/python3-argcomplete: Updated for version 3.0.8.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python/python3-argcomplete/python3-argcomplete.SlackBuild')
-rw-r--r--python/python3-argcomplete/python3-argcomplete.SlackBuild9
1 files changed, 5 insertions, 4 deletions
diff --git a/python/python3-argcomplete/python3-argcomplete.SlackBuild b/python/python3-argcomplete/python3-argcomplete.SlackBuild
index 5822106807..c8299f6bf8 100644
--- a/python/python3-argcomplete/python3-argcomplete.SlackBuild
+++ b/python/python3-argcomplete/python3-argcomplete.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for python3-argcomplete
-# Copyright 2023 Vijay Marcel
+# Copyright 2023-2024 Vijay Marcel
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -25,7 +25,7 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=python3-argcomplete
-VERSION=${VERSION:-2.0.0}
+VERSION=${VERSION:-3.0.8}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -82,10 +82,11 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python3 setup.py install --prefix=/usr --root=$PKG --optimize=1
+python3 -m build --wheel --no-isolation
+python3 -m installer --destdir "$PKG" dist/*.whl
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+ | cut -f 1 -d : | xargs strip --strip-unneeded --remove-section=.comment --remove-section=.note 2> /dev/null || true
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a Authors.rst Changes.rst LICENSE.rst README.rst $PKG/usr/doc/$PRGNAM-$VERSION