aboutsummaryrefslogtreecommitdiff
path: root/python/python2-gattlib/python2-gattlib.SlackBuild
diff options
context:
space:
mode:
authorHeinz Wiesinger <pprkut@slackbuilds.org>2021-09-26 18:07:16 +0200
committerWilly Sudiarto Raharjo <willysr@slackbuilds.org>2021-10-02 16:50:36 +0700
commit683429feac1d178ce48849a588d56201d360bfdc (patch)
treea997b38e2e3a95ec1691ac0a7a4902eba43094bb /python/python2-gattlib/python2-gattlib.SlackBuild
parent38068c6727703048e17687ab4ea1bf525ff5297b (diff)
python/python2-gattlib: Updated for version 0.20200121
Signed-off-by: Heinz Wiesinger <pprkut@slackbuilds.org> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python/python2-gattlib/python2-gattlib.SlackBuild')
-rw-r--r--python/python2-gattlib/python2-gattlib.SlackBuild30
1 files changed, 16 insertions, 14 deletions
diff --git a/python/python2-gattlib/python2-gattlib.SlackBuild b/python/python2-gattlib/python2-gattlib.SlackBuild
index fe1a8c7263..0ac11a3705 100644
--- a/python/python2-gattlib/python2-gattlib.SlackBuild
+++ b/python/python2-gattlib/python2-gattlib.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for python-gattlib
-# Copyright 2017 Heinz Wiesinger, Amsterdam, The Netherlands
+# Copyright 2017-2021 Heinz Wiesinger, Amsterdam, The Netherlands
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -11,22 +11,22 @@
# 1. Redistributions of this script must retain the above copyright
# notice, this list of conditions and the following disclaimer.
#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ``AS IS'' AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=python2-gattlib
-VERSION=${VERSION:-0.20150805}
-BUILD=${BUILD:-2}
+VERSION=${VERSION:-0.20200121}
+BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -67,7 +67,9 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-patch -p1 < $CWD/dont_hardcode_python_versions.patch
+# Point to correct version of boost-python
+sed -i 's/\["boost_python"\]/\["boost_python2"+str(sys.version_info.minor)\]/' \
+ ./setup.py
python2 setup.py install --root=$PKG