aboutsummaryrefslogtreecommitdiff
path: root/python/python-simpy/python-simpy.SlackBuild
diff options
context:
space:
mode:
authorWilly Sudiarto Raharjo <willysr@slackbuilds.org>2017-04-12 06:34:27 +0700
committerWilly Sudiarto Raharjo <willysr@slackbuilds.org>2017-04-13 07:22:25 +0700
commitade3e7559dc7a1a3d190f7f1228ee9d2f3fb6b7d (patch)
treea236b0b4c47be538a1df00bf5e41b6e8da9b3fa8 /python/python-simpy/python-simpy.SlackBuild
parent6a3bd03511812a005946aaf9f4fd7d940553d7f6 (diff)
python/python-simpy: Updated for version 3.0.10.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python/python-simpy/python-simpy.SlackBuild')
-rw-r--r--python/python-simpy/python-simpy.SlackBuild24
1 files changed, 11 insertions, 13 deletions
diff --git a/python/python-simpy/python-simpy.SlackBuild b/python/python-simpy/python-simpy.SlackBuild
index 3fcea3bccc14..f7ce00312db5 100644
--- a/python/python-simpy/python-simpy.SlackBuild
+++ b/python/python-simpy/python-simpy.SlackBuild
@@ -5,15 +5,15 @@
# Written by John Tyree <johntyree+sbo@gmail.com>
PRGNAM=python-simpy
-VERSION=${VERSION:-2.2}
+VERSION=${VERSION:-3.0.10}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
-SRCNAM=SimPy
+SRCNAM=simpy
DOCS=${DOCS:-"no"}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
- i?86) ARCH=i486 ;;
+ i?86) ARCH=i586 ;;
arm*) ARCH=arm ;;
*) ARCH=$( uname -m ) ;;
esac
@@ -24,8 +24,8 @@ TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
-if [ "$ARCH" = "i486" ]; then
- SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
LIBDIRSUFFIX=""
elif [ "$ARCH" = "i686" ]; then
SLKCFLAGS="-O2 -march=i686 -mtune=i686"
@@ -44,18 +44,17 @@ rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
rm -rf $SRCNAM-$VERSION
-tar xvf $CWD/$SRCNAM-$VERSION.tar.bz2
+tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
cd $SRCNAM-$VERSION
chown -R root:root .
find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
- -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \;
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
python setup.py install --root=$PKG
-# Strip binaries and libraries.
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
@@ -63,8 +62,7 @@ mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
if [[ $DOCS == "yes" ]]; then
(cd ./docs; make html; cp -a html $PKG/usr/doc/$PRGNAM-$VERSION)
fi
-cp -a \
- AUTHORS.txt CHANGES.txt LICENSE.txt README.txt docs/examples \
+cp -a AUTHORS.txt CHANGES.txt LICENSE.txt README.txt docs/examples \
$PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild