aboutsummaryrefslogtreecommitdiff
path: root/python/python-oauthlib/python-oauthlib.SlackBuild
diff options
context:
space:
mode:
authorDimitris Zlatanidis <d.zlatanidis@gmail.com>2019-12-25 18:22:14 +0100
committerWilly Sudiarto Raharjo <willysr@slackbuilds.org>2019-12-31 18:06:26 +0700
commit6c307a933c404d8149da4a4170c12cb7753dd368 (patch)
tree8bce7f775e34e5f2ea83daed71bd051943ecef24 /python/python-oauthlib/python-oauthlib.SlackBuild
parent23394e3bf89bee106759f25db3da9013ad384a6c (diff)
downloadslackbuilds-6c307a933c404d8149da4a4170c12cb7753dd368.tar.xz
python/python-oauthlib: Updated for version 3.1.0.
Signed-off-by: Dimitris Zlatanidis <d.zlatanidis@gmail.com>
Diffstat (limited to 'python/python-oauthlib/python-oauthlib.SlackBuild')
-rw-r--r--python/python-oauthlib/python-oauthlib.SlackBuild9
1 files changed, 7 insertions, 2 deletions
diff --git a/python/python-oauthlib/python-oauthlib.SlackBuild b/python/python-oauthlib/python-oauthlib.SlackBuild
index 83419d716559..469532ccda77 100644
--- a/python/python-oauthlib/python-oauthlib.SlackBuild
+++ b/python/python-oauthlib/python-oauthlib.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for python-oauthlib
-# Copyright 2014-2018 Dimitris Zlatanidis Orestiada, Greece
+# Copyright 2014-2019 Dimitris Zlatanidis Orestiada, Greece
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -24,7 +24,7 @@
PRGNAM=python-oauthlib
SRCNAM=$(echo $PRGNAM | cut -c8-15)
-VERSION=${VERSION:-2.1.0}
+VERSION=${VERSION:-3.1.0}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -72,6 +72,11 @@ find -L . \
python setup.py install --root=$PKG
+# python3 support
+if $(python3 -c 'import sys' 2>/dev/null); then
+ python3 setup.py install --root=$PKG
+fi
+
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true