aboutsummaryrefslogtreecommitdiff
path: root/python/python-libarchive-c/python-libarchive-c.SlackBuild
diff options
context:
space:
mode:
authorMatt Egger <matt.egger@gmail.com>2024-09-25 16:00:54 -0400
committerWilly Sudiarto Raharjo <willysr@slackbuilds.org>2024-09-27 23:12:13 +0700
commit7f77b0d00db11cd1c3e6fb361e24e80adfb32b00 (patch)
tree71998aa4a5fa45ac9d62e6ac7c1c4417c36794ad /python/python-libarchive-c/python-libarchive-c.SlackBuild
parent1caa032192642f4a3bb80730157230586a930383 (diff)
python/python-libarchive-c: updated for version 5.1
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python/python-libarchive-c/python-libarchive-c.SlackBuild')
-rw-r--r--python/python-libarchive-c/python-libarchive-c.SlackBuild18
1 files changed, 6 insertions, 12 deletions
diff --git a/python/python-libarchive-c/python-libarchive-c.SlackBuild b/python/python-libarchive-c/python-libarchive-c.SlackBuild
index a0b5481e7e..71058b1771 100644
--- a/python/python-libarchive-c/python-libarchive-c.SlackBuild
+++ b/python/python-libarchive-c/python-libarchive-c.SlackBuild
@@ -2,6 +2,7 @@
# Slackware build script for python-libarchive-c
+# Copyright 2024 Matt Egger, USA
# Copyright 2016 David Spencer, Baildon, West Yorkshire, U.K.
# All rights reserved.
#
@@ -25,13 +26,11 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=python-libarchive-c
-VERSION=${VERSION:-2.8}
+VERSION=${VERSION:-5.1}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
-SRCNAM="$(printf $PRGNAM | cut -d- -f2-)"
-
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
i?86) ARCH=i586 ;;
@@ -71,9 +70,9 @@ set -e
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
-rm -rf $SRCNAM-$VERSION
-tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
-cd $SRCNAM-$VERSION
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
@@ -81,12 +80,7 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python setup.py install --root=$PKG
-
-if [ "${PYTHON3:-no}" = "yes" ]; then
- rm -rf build
- python3 setup.py install --root=$PKG
-fi
+python3 setup.py install --root=$PKG
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true