aboutsummaryrefslogtreecommitdiff
path: root/python/python-MonthDelta
diff options
context:
space:
mode:
authorDave Woodfall <dave@slackbuilds.org>2021-05-03 06:48:48 +0100
committerRobby Workman <rworkman@slackbuilds.org>2021-05-03 01:49:56 -0500
commit24da8b89415d43a711dedef83848ad656ef32d40 (patch)
treef71cdb1318e490ce41882a49cc769100771c283a /python/python-MonthDelta
parente5286256a9fd41c98637113ff48617051fcaec3f (diff)
python/python-MonthDelta: Renamed python2-MonthDelta.
Signed-off-by: Dave Woodfall <dave@slackbuilds.org>
Diffstat (limited to 'python/python-MonthDelta')
-rw-r--r--python/python-MonthDelta/README9
-rw-r--r--python/python-MonthDelta/python-MonthDelta.SlackBuild87
-rw-r--r--python/python-MonthDelta/python-MonthDelta.info10
-rw-r--r--python/python-MonthDelta/slack-desc19
4 files changed, 0 insertions, 125 deletions
diff --git a/python/python-MonthDelta/README b/python/python-MonthDelta/README
deleted file mode 100644
index 35deb5aa0eb9..000000000000
--- a/python/python-MonthDelta/README
+++ /dev/null
@@ -1,9 +0,0 @@
-python-MonthDelta (Pythonic date calculation with months)
-
-monthdelta.py includes a class, MonthDelta, and a function, monthmod().
-
-MonthDelta enables easy month-related calculations with the standard
-Python date and datetime classes from the datetime module.
-
-monthmod() enables round-trip calculations among MonthDelta, date,
-datetime, and timedelta.
diff --git a/python/python-MonthDelta/python-MonthDelta.SlackBuild b/python/python-MonthDelta/python-MonthDelta.SlackBuild
deleted file mode 100644
index d253f53d503b..000000000000
--- a/python/python-MonthDelta/python-MonthDelta.SlackBuild
+++ /dev/null
@@ -1,87 +0,0 @@
-#!/bin/sh
-
-# Slackware build script for python-MonthDelta
-
-# Copyright 2011,2014 Christophe Nguyen
-# All rights reserved.
-#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
-PRGNAM=python-MonthDelta
-VERSION=${VERSION:-1.0b}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-
-SRCNAM=$(echo $PRGNAM | cut -d- -f2)
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i486 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-CWD=$(pwd)
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-if [ "$ARCH" = "i486" ]; then
- SLKCFLAGS="-O2 -march=i486 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $SRCNAM-$VERSION
-tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
-cd $SRCNAM-$VERSION
-chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-
-python setup.py install --root=$PKG
-
-find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a README.rst PKG-INFO *.txt doc/* $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/python-MonthDelta/python-MonthDelta.info b/python/python-MonthDelta/python-MonthDelta.info
deleted file mode 100644
index 1848702ac3a4..000000000000
--- a/python/python-MonthDelta/python-MonthDelta.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="python-MonthDelta"
-VERSION="1.0b"
-HOMEPAGE="https://pypi.python.org/pypi/MonthDelta"
-DOWNLOAD="https://pypi.python.org/packages/source/M/MonthDelta/MonthDelta-1.0b.tar.gz"
-MD5SUM="0030e741699a1b4d03176e0d13f12864"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES=""
-MAINTAINER="Christophe Nguyen"
-EMAIL="cnguyenminhtan@free.fr"
diff --git a/python/python-MonthDelta/slack-desc b/python/python-MonthDelta/slack-desc
deleted file mode 100644
index e888cc40f103..000000000000
--- a/python/python-MonthDelta/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-python-MonthDelta: python-MonthDelta (Pythonic date calculation with months)
-python-MonthDelta:
-python-MonthDelta: Date computations with months
-python-MonthDelta:
-python-MonthDelta: Homepage: https://pypi.python.org/pypi/MonthDelta
-python-MonthDelta:
-python-MonthDelta:
-python-MonthDelta:
-python-MonthDelta:
-python-MonthDelta:
-python-MonthDelta: