aboutsummaryrefslogtreecommitdiff
path: root/python/pyliblo/pyliblo.SlackBuild
diff options
context:
space:
mode:
authorB. Watson <yalhcru@gmail.com>2021-12-02 12:07:41 -0500
committerWilly Sudiarto Raharjo <willysr@slackbuilds.org>2021-12-10 08:37:33 +0700
commit32c714630e527a88974139eba0f478940ab5358d (patch)
tree260e0cd12f1200be9625bff08f632c87486f16cc /python/pyliblo/pyliblo.SlackBuild
parent9a84afbc929318c2ddf168cd561fbc35eca91f8e (diff)
python/pyliblo: Add python3 support.
Signed-off-by: B. Watson <yalhcru@gmail.com> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python/pyliblo/pyliblo.SlackBuild')
-rw-r--r--python/pyliblo/pyliblo.SlackBuild22
1 files changed, 9 insertions, 13 deletions
diff --git a/python/pyliblo/pyliblo.SlackBuild b/python/pyliblo/pyliblo.SlackBuild
index 327e7f751a..dbaa0c3c60 100644
--- a/python/pyliblo/pyliblo.SlackBuild
+++ b/python/pyliblo/pyliblo.SlackBuild
@@ -6,11 +6,13 @@
# Licensed under the WTFPL. See http://www.wtfpl.net/txt/copying/ for details.
+# 20211202 bkw: BUILD=2, add python3 support.
+
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=pyliblo
VERSION=${VERSION:-0.10.0}
-BUILD=${BUILD:-1}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -22,9 +24,6 @@ if [ -z "$ARCH" ]; then
esac
fi
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
@@ -57,21 +56,18 @@ rm -rf $PRGNAM-$VERSION
tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
cd $PRGNAM-$VERSION
chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
- -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \;
+find -L . -perm /111 -a \! -perm 755 -a -exec chmod 755 {} \+ -o \
+ \! -perm /111 -a \! -perm 644 -a -exec chmod 644 {} \+
python setup.py install --root=$PKG
-find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+python3 setup.py install --root=$PKG
+
+find $PKG/usr/lib* -name '*.so' -exec strip {} \+
mv $PKG/usr/share/man $PKG/usr/man
rmdir $PKG/usr/share
-find $PKG/usr/man -type f -exec gzip -9 {} \;
-for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
+gzip -9 $PKG/usr/man/man?/*
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a COPYING NEWS PKG-INFO README $PKG/usr/doc/$PRGNAM-$VERSION