aboutsummaryrefslogtreecommitdiff
path: root/python/py-cpuinfo/py-cpuinfo.SlackBuild
diff options
context:
space:
mode:
authorPhilip Lacroix <slackph at posteo dot de>2017-02-12 07:40:51 +0700
committerWilly Sudiarto Raharjo <willysr@slackbuilds.org>2017-02-18 07:54:03 +0700
commitf1d6b7289d01ffc4e143699434687826f40d0bce (patch)
tree14b33e6e46b2b1c89b96081541cbbd72ef781e64 /python/py-cpuinfo/py-cpuinfo.SlackBuild
parent5deec19f44bdf565de479803116c7f53e21ff070 (diff)
downloadslackbuilds-f1d6b7289d01ffc4e143699434687826f40d0bce.tar.xz
python/py-cpuinfo: Added (retrieve CPU information).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python/py-cpuinfo/py-cpuinfo.SlackBuild')
-rw-r--r--python/py-cpuinfo/py-cpuinfo.SlackBuild78
1 files changed, 78 insertions, 0 deletions
diff --git a/python/py-cpuinfo/py-cpuinfo.SlackBuild b/python/py-cpuinfo/py-cpuinfo.SlackBuild
new file mode 100644
index 000000000000..297deebfe2c0
--- /dev/null
+++ b/python/py-cpuinfo/py-cpuinfo.SlackBuild
@@ -0,0 +1,78 @@
+#!/bin/sh
+
+# Slackware build script for py-cpuinfo
+
+# Copyright 2017 Philip Lacroix <slackph at posteo dot de>
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=py-cpuinfo
+VERSION=${VERSION:-20170112}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+# Source ID (GitHub).
+SRCVER=${SRCVER:-c07382c374f4c400f0f2796d81c17e271350e543}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=${PKG:-$TMP/package-$PRGNAM}
+OUTPUT=${OUTPUT:-/tmp}
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$SRCVER
+tar xvzf $CWD/$PRGNAM-$SRCVER.tar.gz
+
+cd $PRGNAM-$SRCVER
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 \
+ -o -perm 400 \) -exec chmod 644 {} \;
+
+python setup.py install --root=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" \
+ | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+PRGDOC=$PKG/usr/doc/$PRGNAM-$VERSION
+
+# Install documentation.
+mkdir -p $PRGDOC
+cp -a ChangeLog LICENSE README.md $PRGDOC/
+cat $CWD/$PRGNAM.SlackBuild > $PRGDOC/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}