aboutsummaryrefslogtreecommitdiff
path: root/python/pickleshare/pickleshare.SlackBuild
diff options
context:
space:
mode:
authorBenjamin Trigona-Harany <bosth@alumni.sfu.ca>2019-06-07 05:34:11 -0700
committerWilly Sudiarto Raharjo <willysr@slackbuilds.org>2019-06-09 05:33:16 +0700
commitfa33224244deb63dc40b1db5b1c6b9a9f6d16c1d (patch)
tree78642d2c242da9b9a62a2a31e75dac0a1c411bb9 /python/pickleshare/pickleshare.SlackBuild
parent24413e5cdcde81e9ad22d29d5bf2f273c076430f (diff)
downloadslackbuilds-fa33224244deb63dc40b1db5b1c6b9a9f6d16c1d.tar.xz
python/pickleshare: Add Python 3 support.
Signed-off-by: Benjamin Trigona-Harany <bosth@alumni.sfu.ca>
Diffstat (limited to 'python/pickleshare/pickleshare.SlackBuild')
-rw-r--r--python/pickleshare/pickleshare.SlackBuild7
1 files changed, 4 insertions, 3 deletions
diff --git a/python/pickleshare/pickleshare.SlackBuild b/python/pickleshare/pickleshare.SlackBuild
index a6c106159277..99a854da62ba 100644
--- a/python/pickleshare/pickleshare.SlackBuild
+++ b/python/pickleshare/pickleshare.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for pickleshare
-# Copyright 2017-2018 Benjamin Trigona-Harany <slackbuilds@jaxartes.net>
+# Copyright 2017-2019 Benjamin Trigona-Harany <slackbuilds@jaxartes.net>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -24,7 +24,7 @@
PRGNAM=pickleshare
VERSION=${VERSION:-0.7.5}
-BUILD=${BUILD:-1}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
@@ -69,7 +69,8 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python setup.py install --root=$PKG
+python2 setup.py install --root=$PKG
+python3 setup.py install --root=$PKG
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true