aboutsummaryrefslogtreecommitdiff
path: root/python/jellyfish
diff options
context:
space:
mode:
authorfourtysixandtwo <fourtysixandtwo@sliderr.net>2024-07-28 05:20:05 -0600
committerWilly Sudiarto Raharjo <willysr@slackbuilds.org>2024-08-03 15:05:23 +0700
commit66396dc6aa1df03f1c309cfdd52cc9241b53ae0c (patch)
tree87dcd2b218fe176361e85e6722a261e4d47d543e /python/jellyfish
parentd5a45dae13c23806f4447f6638b251d0fb06d2e9 (diff)
python/jellyfish: Updated for version 1.1.0.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python/jellyfish')
-rw-r--r--python/jellyfish/Cargo-toml.patch12
-rw-r--r--python/jellyfish/jellyfish.SlackBuild8
-rw-r--r--python/jellyfish/jellyfish.info10
3 files changed, 8 insertions, 22 deletions
diff --git a/python/jellyfish/Cargo-toml.patch b/python/jellyfish/Cargo-toml.patch
deleted file mode 100644
index be934640c89f..000000000000
--- a/python/jellyfish/Cargo-toml.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-diff --git a/Cargo.toml b/Cargo.toml
-index 6f9bf52..2deead4 100644
---- a/Cargo.toml
-+++ b/Cargo.toml
-@@ -20,6 +20,7 @@ unicode-segmentation = "^1.6.0"
- unicode-normalization = "^0.1"
- smallvec = "1.10.0"
- ahash = "0.8.3"
-+syn = "2.0.37"
-
- [dev-dependencies]
- csv = "1.1"
diff --git a/python/jellyfish/jellyfish.SlackBuild b/python/jellyfish/jellyfish.SlackBuild
index a3086a5bf469..d1d2535d5748 100644
--- a/python/jellyfish/jellyfish.SlackBuild
+++ b/python/jellyfish/jellyfish.SlackBuild
@@ -29,7 +29,7 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=jellyfish
-VERSION=${VERSION:-1.0.4}
+VERSION=${VERSION:-1.1.0}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -85,9 +85,6 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \+
-# patch Cargo.toml to include missing dep when using filtered sources
-patch --no-backup-if-mismatch -Np1 < $CWD/Cargo-toml.patch
-
# prevent cargo from using the network.
# this only works because we have a vendored sources tarball with
# everything cargo would have downloaded.
@@ -106,7 +103,8 @@ fi
PYVER=$(python3 -c 'import sys; print("%d.%d" % sys.version_info[:2])')
export PYTHONPATH=/opt/python$PYVER/site-packages/
-python3 -m build --no-isolation
+# building from sdist is broken with python3-maturin-1.7.0
+python3 -m build --wheel --no-isolation
python3 -m installer -d "$PKG" dist/*.whl
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
diff --git a/python/jellyfish/jellyfish.info b/python/jellyfish/jellyfish.info
index c09cbf4d46cf..bb6eee646c97 100644
--- a/python/jellyfish/jellyfish.info
+++ b/python/jellyfish/jellyfish.info
@@ -1,10 +1,10 @@
PRGNAM="jellyfish"
-VERSION="1.0.4"
+VERSION="1.1.0"
HOMEPAGE="https://github.com/sunlightlabs/jellyfish"
-DOWNLOAD="https://files.pythonhosted.org/packages/source/j/jellyfish/jellyfish-1.0.4.tar.gz \
- https://slackware.uk/~fourtysixandtwo/src/jellyfish-vendored-sources-1.0.4-1.tar.xz"
-MD5SUM="22f455715f501202b7fbf678ca97eb31 \
- 0c89e6ecdb6ae819476e04382a370f27"
+DOWNLOAD="https://files.pythonhosted.org/packages/source/j/jellyfish/jellyfish-1.1.0.tar.gz \
+ https://slackware.uk/~fourtysixandtwo/src/jellyfish-vendored-sources-1.1.0-1.tar.xz"
+MD5SUM="40022ca4173441d95665568adb5f277b \
+ 7fc47cc4f769ba858e703084a78aea40"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES="python3-maturin"