aboutsummaryrefslogtreecommitdiff
path: root/python/hupper
diff options
context:
space:
mode:
authorArn0 <yth@ythogtha.org>2022-03-08 23:29:22 +0100
committerWilly Sudiarto Raharjo <willysr@slackbuilds.org>2022-03-09 12:22:19 +0700
commit42f6cb5b8a98a0e62c712d21f4cb6210f175e82b (patch)
tree2e16675d0e683c7eaf09c8c1a40aa13438aca036 /python/hupper
parentfc8ab129e60631f3ab328fab5ca174a7063ac155 (diff)
python/python3-hupper: renamed from hupper for python3, updated for version 1.10.3
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python/hupper')
-rw-r--r--python/hupper/README3
-rw-r--r--python/hupper/hupper.SlackBuild79
-rw-r--r--python/hupper/hupper.info10
-rw-r--r--python/hupper/slack-desc19
4 files changed, 0 insertions, 111 deletions
diff --git a/python/hupper/README b/python/hupper/README
deleted file mode 100644
index 7205639b5900..000000000000
--- a/python/hupper/README
+++ /dev/null
@@ -1,3 +0,0 @@
-hupper is an integrated process monitor that will track changes to any imported
-Python files in sys.modules as well as custom paths.
-When files are changed the process is restarted.
diff --git a/python/hupper/hupper.SlackBuild b/python/hupper/hupper.SlackBuild
deleted file mode 100644
index 8560087bd93b..000000000000
--- a/python/hupper/hupper.SlackBuild
+++ /dev/null
@@ -1,79 +0,0 @@
-#!/bin/bash
-
-# SlackBuild script for hupper.
-# Yth | Pont-en-Royans, France | yth@ythogtha.org
-
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
-cd $(dirname $0) ; CWD=$(pwd)
-
-PRGNAM=hupper
-VERSION=${VERSION:-1.9.1}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-PKGTYPE=${PKGTYPE:-tgz}
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i586 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
-if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
- echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
- exit 0
-fi
-
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
-cd $PRGNAM-$VERSION
-chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-
-python setup.py install --root=$PKG
-if $(python3 -c 'import sys' 2>/dev/null); then
- python3 setup.py install --root=$PKG
-fi
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a README.rst $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/python/hupper/hupper.info b/python/hupper/hupper.info
deleted file mode 100644
index c647ea63869b..000000000000
--- a/python/hupper/hupper.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="hupper"
-VERSION="1.9.1"
-HOMEPAGE="https://github.com/Pylons/hupper"
-DOWNLOAD="https://pypi.python.org/packages/source/h/hupper/hupper-1.9.1.tar.gz"
-MD5SUM="5dd80c6cf45045f74aed5a2f4bd0d18e"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES=""
-MAINTAINER="Yth - Arnaud"
-EMAIL="yth@ythogtha.org"
diff --git a/python/hupper/slack-desc b/python/hupper/slack-desc
deleted file mode 100644
index 934af1e4549a..000000000000
--- a/python/hupper/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-hupper: hupper (Python Module)
-hupper:
-hupper: in-process file monitor / reloader for reloading your code
-hupper: automatically during development
-hupper:
-hupper:
-hupper:
-hupper:
-hupper:
-hupper:
-hupper: