aboutsummaryrefslogtreecommitdiff
path: root/python/flake8/flake8.SlackBuild
diff options
context:
space:
mode:
authorDimitris Zlatanidis <d.zlatanidis@gmail.com>2022-12-15 22:31:01 +0200
committerWilly Sudiarto Raharjo <willysr@slackbuilds.org>2022-12-17 09:13:52 +0700
commit9e85088967461078ecb25cd638d23f9688e0be56 (patch)
tree6b998f21123d7c08015076de476c6caa482859e6 /python/flake8/flake8.SlackBuild
parent6b58522f1fe26436af2e5d65704dc869e366cee3 (diff)
python/flake8: Updated for version 6.0.0.
Signed-off-by: Dimitris Zlatanidis <d.zlatanidis@gmail.com> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python/flake8/flake8.SlackBuild')
-rw-r--r--python/flake8/flake8.SlackBuild11
1 files changed, 4 insertions, 7 deletions
diff --git a/python/flake8/flake8.SlackBuild b/python/flake8/flake8.SlackBuild
index e5593b72c1ec..c2daaefc9745 100644
--- a/python/flake8/flake8.SlackBuild
+++ b/python/flake8/flake8.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for flake8
-# Copyright 2014-2017 Dimitris Zlatanidis Orestiada, Greece
+# Copyright 2014-2022 Dimitris Zlatanidis Orestiada, Greece
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -25,8 +25,8 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=flake8
-VERSION=${VERSION:-3.5.0}
-BUILD=${BUILD:-2}
+VERSION=${VERSION:-6.0.0}
+BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -79,10 +79,7 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-# Ignores setuptools version, it works for me
-sed -i "s/setuptools >= 30\",/\"/" setup.py
-
-python2 setup.py install --root=$PKG
+python3 setup.py install --root=$PKG
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true