aboutsummaryrefslogtreecommitdiff
path: root/python/entrypoints
diff options
context:
space:
mode:
authorBenjamin Trigona-Harany <slackbuilds@jaxartes.net>2021-04-21 20:33:13 +0200
committerWilly Sudiarto Raharjo <willysr@slackbuilds.org>2021-05-02 17:21:03 +0700
commit3ced68db733ff4d66d98286d30d4217c1e17f859 (patch)
tree316902c50951a792beb3287bdc18ef4591c1ec2e /python/entrypoints
parent546a8b06dcce5b018724e29ea42f2979803f6597 (diff)
python/entrypoints: Remove Python 2 support.
Signed-off-by: Benjamin Trigona-Harany <slackbuilds@jaxartes.net> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python/entrypoints')
-rw-r--r--python/entrypoints/entrypoints.SlackBuild3
-rw-r--r--python/entrypoints/setup.py1
2 files changed, 1 insertions, 3 deletions
diff --git a/python/entrypoints/entrypoints.SlackBuild b/python/entrypoints/entrypoints.SlackBuild
index 76f2e3edb85e..2c1f2f4e319a 100644
--- a/python/entrypoints/entrypoints.SlackBuild
+++ b/python/entrypoints/entrypoints.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for entrypoints
-# Copyright 2017-2019 Benjamin Trigona-Harany <slackbuilds@jaxartes.net>
+# Copyright 2017-2021 Benjamin Trigona-Harany <slackbuilds@jaxartes.net>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -70,7 +70,6 @@ find -L . \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
cp $CWD/setup.py .
-python2 setup.py install --root=$PKG
python3 setup.py install --root=$PKG
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
diff --git a/python/entrypoints/setup.py b/python/entrypoints/setup.py
index e278244224b8..402c431bec1e 100644
--- a/python/entrypoints/setup.py
+++ b/python/entrypoints/setup.py
@@ -1,4 +1,3 @@
-
from setuptools import setup, find_packages
setup(