aboutsummaryrefslogtreecommitdiff
path: root/python/ecdsa/ecdsa.SlackBuild
diff options
context:
space:
mode:
authorWilly Sudiarto Raharjo <willysr@slackbuilds.org>2023-12-08 00:41:08 +0700
committerWilly Sudiarto Raharjo <willysr@slackbuilds.org>2023-12-08 00:41:08 +0700
commita1452cfb793688e319e57086d934d4d2546adf58 (patch)
tree06d721bc22ba069d5c78632fbbfd6b2ccbddd10a /python/ecdsa/ecdsa.SlackBuild
parent03efaf25b282e9b0e1ec8d20664a29d7d4dcd0aa (diff)
python/ecdsa: Updated for version 0.18.0.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python/ecdsa/ecdsa.SlackBuild')
-rw-r--r--python/ecdsa/ecdsa.SlackBuild11
1 files changed, 3 insertions, 8 deletions
diff --git a/python/ecdsa/ecdsa.SlackBuild b/python/ecdsa/ecdsa.SlackBuild
index e3540064f399..006beb22b44e 100644
--- a/python/ecdsa/ecdsa.SlackBuild
+++ b/python/ecdsa/ecdsa.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for ecdsa
-# Copyright 2013-2018 Willy Sudiarto Raharjo <willysr@slackbuilds.org>
+# Copyright 2013-2023 Willy Sudiarto Raharjo <willysr@slackbuilds.org>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -25,7 +25,7 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=ecdsa
-VERSION=${VERSION:-0.13}
+VERSION=${VERSION:-0.18.0}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -38,9 +38,6 @@ if [ -z "$ARCH" ]; then
esac
fi
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
@@ -80,10 +77,8 @@ find -L . \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
python setup.py install --root=$PKG
+python3 setup.py install --root=$PKG
-if $(python3 -c 'import sys' 2>/dev/null); then
- python3 setup.py install --root=$PKG
-fi
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true