aboutsummaryrefslogtreecommitdiff
path: root/python/asn1crypto/asn1crypto.SlackBuild
diff options
context:
space:
mode:
authorIsaac Yu <isaacyu1@isaacyu1.com>2022-10-09 11:16:01 -0700
committerWilly Sudiarto Raharjo <willysr@slackbuilds.org>2022-10-10 23:35:29 +0700
commit0b50e98d35c6baaf164ff1f7defc4391564de0ab (patch)
treed0cdb49268cf86e7188fef68075e7580b92e0413 /python/asn1crypto/asn1crypto.SlackBuild
parentf55cac87949a9f43ebf86f65a19609be73e02086 (diff)
python/asn1crypto: Update for 1.5.1 (+new maintainer)
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python/asn1crypto/asn1crypto.SlackBuild')
-rw-r--r--python/asn1crypto/asn1crypto.SlackBuild11
1 files changed, 4 insertions, 7 deletions
diff --git a/python/asn1crypto/asn1crypto.SlackBuild b/python/asn1crypto/asn1crypto.SlackBuild
index 5e967662ccb0..5fbdf2e27e0a 100644
--- a/python/asn1crypto/asn1crypto.SlackBuild
+++ b/python/asn1crypto/asn1crypto.SlackBuild
@@ -3,6 +3,7 @@
# Slackware build script for asn1crypto
#
# Copyright 2017-2018 Markus Reichelt, Aachen, DE
+# Copyright 2022 Isaac Yu <isaacyu1@isaacyu1.com>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -25,7 +26,7 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=asn1crypto
-VERSION=${VERSION:-0.24.0}
+VERSION=${VERSION:-1.5.1}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -81,17 +82,13 @@ find -L . \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
python setup.py install --root=$PKG
-
-# Python 3 support.
-if $(python3 -c 'import sys' 2>/dev/null); then
- python3 setup.py install --root=$PKG
-fi
+python3 setup.py install --root=$PKG
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a LICENSE changelog.* docs/* $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a LICENSE changelog.md docs/* $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install