aboutsummaryrefslogtreecommitdiff
path: root/python/argon2-cffi-bindings
diff options
context:
space:
mode:
authorIsaac Yu <isaacyu1@isaacyu1.com>2022-10-08 01:29:02 -0700
committerWilly Sudiarto Raharjo <willysr@slackbuilds.org>2022-10-10 23:34:34 +0700
commit0eefdb011b092fc09bbe43f997d9efc1b9637b3e (patch)
tree0dfa0a5684955ed12300c521dca5537a1a049485 /python/argon2-cffi-bindings
parentb830d017cfac97dd14cd92a43a9db2ae29460537 (diff)
python/argon2-cffi-bindings: Use system argon2
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python/argon2-cffi-bindings')
-rw-r--r--python/argon2-cffi-bindings/argon2-cffi-bindings.SlackBuild7
1 files changed, 5 insertions, 2 deletions
diff --git a/python/argon2-cffi-bindings/argon2-cffi-bindings.SlackBuild b/python/argon2-cffi-bindings/argon2-cffi-bindings.SlackBuild
index 878d3da3543d..0212dea236d2 100644
--- a/python/argon2-cffi-bindings/argon2-cffi-bindings.SlackBuild
+++ b/python/argon2-cffi-bindings/argon2-cffi-bindings.SlackBuild
@@ -26,7 +26,7 @@ cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=argon2-cffi-bindings
VERSION=${VERSION:-21.2.0}
-BUILD=${BUILD:-1}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -38,6 +38,9 @@ if [ -z "$ARCH" ]; then
esac
fi
+# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
+# the name of the created package would be, and then exit. This information
+# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
@@ -76,7 +79,7 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 \
-o -perm 400 \) -exec chmod 644 {} \;
-python3 setup.py install --root=$PKG
+ARGON2_CFFI_USE_SYSTEM=1 python3 setup.py install --root=$PKG
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true