aboutsummaryrefslogtreecommitdiff
path: root/network
diff options
context:
space:
mode:
authorWilly Sudiarto Raharjo <willysr@slackbuilds.org>2024-10-02 12:08:51 +0700
committerWilly Sudiarto Raharjo <willysr@slackbuilds.org>2024-10-02 19:06:09 +0700
commitf2931a260a5d3349446f18a74548c4e653647c49 (patch)
tree7871605e72be2077a0b0611275b9907f289ae347 /network
parentea4664c0df792249f26d1e98b08dcf29641ccadc (diff)
network/protonvpn-cli: Removed (Stopped Working).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'network')
-rw-r--r--network/protonvpn-cli/README24
-rw-r--r--network/protonvpn-cli/protonvpn-cli.SlackBuild78
-rw-r--r--network/protonvpn-cli/protonvpn-cli.info10
-rw-r--r--network/protonvpn-cli/slack-desc19
4 files changed, 0 insertions, 131 deletions
diff --git a/network/protonvpn-cli/README b/network/protonvpn-cli/README
deleted file mode 100644
index 39b64af12ff8e..0000000000000
--- a/network/protonvpn-cli/README
+++ /dev/null
@@ -1,24 +0,0 @@
-protonvpn-cli is the community Linux command line tool for connecting to
-the ProtonVPN. It is a full rewrite of the original bash protonvpn-cli
-in Python, which adds more features and functionality with the purpose
-of improving readability, speed, and reliability.
-
-Before using protonvpn-cli, it must be initialized. Run (as root)
-
- protonvpn init
-
-and follow the prompts on the screen. Your OpenVPN username and password
-can be found at https://account.protonvpn.com/account. Note that both
-free and paid accounts are supported.
-
-After protonvpn-cli is configured, run (as root)
-
- protonvpn connect -f
-
-to connect to ProtonVPN using the fastest available server.
-
-Before uninstalling, run
-
- protonvpn configure
-
-to purge the configuration files.
diff --git a/network/protonvpn-cli/protonvpn-cli.SlackBuild b/network/protonvpn-cli/protonvpn-cli.SlackBuild
deleted file mode 100644
index 66d41825216f7..0000000000000
--- a/network/protonvpn-cli/protonvpn-cli.SlackBuild
+++ /dev/null
@@ -1,78 +0,0 @@
-#!/bin/bash
-
-# Slackware build script for protonvpn-cli
-
-# Copyright 2019-2024 Erich Ritz, Jenks, Oklahoma, USA
-# All rights reserved.
-#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
-cd $(dirname $0) ; CWD=$(pwd)
-
-PRGNAM=protonvpn-cli
-SRCNAM=linux-cli-community
-VERSION=${VERSION:-2.2.12}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-PKGTYPE=${PKGTYPE:-tgz}
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i586 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
- echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
- exit 0
-fi
-
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $SRCNAM-$VERSION
-tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
-cd $SRCNAM-$VERSION
-chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-
-python3 setup.py install --root=$PKG
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a \
- AUTHORS CHANGELOG.md LICENSE README.md USAGE.md \
- $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/network/protonvpn-cli/protonvpn-cli.info b/network/protonvpn-cli/protonvpn-cli.info
deleted file mode 100644
index f112b73fa1dd0..0000000000000
--- a/network/protonvpn-cli/protonvpn-cli.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="protonvpn-cli"
-VERSION="2.2.12"
-HOMEPAGE="https://github.com/Rafficer/linux-cli-community"
-DOWNLOAD="https://github.com/Rafficer/linux-cli-community/archive/refs/tags/v2.2.12/linux-cli-community-2.2.12.tar.gz"
-MD5SUM="cd9ebf7d3767b8df2156fcbe325c5cae"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES="python3-docopt python3-pythondialog"
-MAINTAINER="Erich Ritz"
-EMAIL="erich.public@protonmail.com"
diff --git a/network/protonvpn-cli/slack-desc b/network/protonvpn-cli/slack-desc
deleted file mode 100644
index 7ad3361d51ed8..0000000000000
--- a/network/protonvpn-cli/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-protonvpn-cli: protonvpn-cli (ProtonVPN's Linux Command-Line Interface)
-protonvpn-cli:
-protonvpn-cli: Community Linux command line tool for connection to the ProtonVPN. It
-protonvpn-cli: is a full rewrite of the original bash protonvpn-cli in Python, which
-protonvpn-cli: adds more features and functionality with the purpose of improving
-protonvpn-cli: readability, speed, and reliability.
-protonvpn-cli:
-protonvpn-cli: Homepage: https://github.com/Rafficer/linux-cli-community
-protonvpn-cli:
-protonvpn-cli:
-protonvpn-cli: