aboutsummaryrefslogtreecommitdiff
path: root/network
diff options
context:
space:
mode:
authorJuan M. Lasca <juanmlasca@gmail.com>2023-03-02 21:33:47 +0000
committerWilly Sudiarto Raharjo <willysr@slackbuilds.org>2023-03-04 08:06:23 +0700
commitb534b8b2d01b764dc57e5f91169fc07655c7d007 (patch)
tree9b80b6f187fc7eeafc549b4da992a6651541007b /network
parent9125c074e01e35f61ffbe007d4375509f18358b5 (diff)
downloadslackbuilds-b534b8b2d01b764dc57e5f91169fc07655c7d007.tar.xz
network/httpie: Updated for version 3.2.1. New maintainer.
Signed-off-by: bedlam <dave@slackbuilds.org> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'network')
-rw-r--r--network/httpie/doinst.sh3
-rw-r--r--network/httpie/httpie.SlackBuild64
-rw-r--r--network/httpie/httpie.info14
3 files changed, 31 insertions, 50 deletions
diff --git a/network/httpie/doinst.sh b/network/httpie/doinst.sh
deleted file mode 100644
index 5fb28930db0b..000000000000
--- a/network/httpie/doinst.sh
+++ /dev/null
@@ -1,3 +0,0 @@
-if [ -x /usr/bin/update-desktop-database ]; then
- /usr/bin/update-desktop-database -q usr/share/applications >/dev/null 2>&1
-fi
diff --git a/network/httpie/httpie.SlackBuild b/network/httpie/httpie.SlackBuild
index 7cf1218d08bb..ec0deab3104b 100644
--- a/network/httpie/httpie.SlackBuild
+++ b/network/httpie/httpie.SlackBuild
@@ -3,6 +3,7 @@
# Slackware build script for httpie
# Copyright 2014-2019 Dimitris Zlatanidis Orestiada, Greece
+# Copyright 2023 Juan M. Lasca <juanmlasca@gmail.com>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -25,45 +26,22 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=httpie
-VERSION=${VERSION:-1.0.3}
-BUILD=${BUILD:-2}
+VERSION=${VERSION:-3.2.1}
+BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
+ARCH=noarch
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i586 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
- echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
- exit 0
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
fi
TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
-if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-O2 -march=i586 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
set -e
rm -rf $PKG
@@ -74,28 +52,34 @@ tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
cd $PRGNAM-$VERSION
chown -R root:root .
find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python3 setup.py install --root=$PKG
-python setup.py install --root=$PKG
+mv $PKG/usr/share/man $PKG/usr/man
+rmdir $PKG/usr/share
-# Python 3 support.
-if $(python3 -c 'import sys' 2>/dev/null); then
- python3 setup.py install --root=$PKG
+# A package compiled in a 64-bit system should be installable
+# on any other architecture.
+if [ -d $PKG/usr/lib64 ]; then
+ mv $PKG/usr/lib64 $PKG/usr/lib
fi
-find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+find $PKG/usr/man -type f -exec gzip -9 {} \;
+for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a LICENSE PKG-INFO README.rst $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a \
+ AUTHORS.md LICENSE SECURITY.md CHANGELOG.md \
+ README.md CONTRIBUTING.md \
+ $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
-cat $CWD/doinst.sh > $PKG/install/doinst.sh
cd $PKG
/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/network/httpie/httpie.info b/network/httpie/httpie.info
index 00184be801e1..1bc79411f02d 100644
--- a/network/httpie/httpie.info
+++ b/network/httpie/httpie.info
@@ -1,10 +1,10 @@
PRGNAM="httpie"
-VERSION="1.0.3"
-HOMEPAGE="https://httpie.org/"
-DOWNLOAD="https://files.pythonhosted.org/packages/d5/a4/ab61c1dbfdef33c7b7f5f7df0d79eb5cd55a106601a4acc17f983f320b4a/httpie-1.0.3.tar.gz"
-MD5SUM="14bfec557e8c81a6cf0ec19140410965"
+VERSION="3.2.1"
+HOMEPAGE="https://httpie.io"
+DOWNLOAD="https://github.com/httpie/httpie/archive/3.2.1/httpie-3.2.1.tar.gz"
+MD5SUM="148fa177c1e1beb692c78051aef83ba7"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
-REQUIRES=""
-MAINTAINER="Dimitris Zlatanidis"
-EMAIL="d.zlatanidis@gmail.com"
+REQUIRES="python3-multidict python3-rich python3-defusedxml PySocks requests-toolbelt"
+MAINTAINER="Juan M. Lasca"
+EMAIL="juanmlasca@gmail.com"