aboutsummaryrefslogtreecommitdiff
path: root/network
diff options
context:
space:
mode:
authorJohn B <irgunii ampersand gmail . com>2024-05-15 22:25:52 +0700
committerWilly Sudiarto Raharjo <willysr@slackbuilds.org>2024-05-16 13:45:47 +0700
commit775b1977842ef7279d55bcab86accc2b10ef037a (patch)
treed1ff2c2ca1c4006055ab6597cf84a5ceb3ab934a /network
parent16e50a2df2c0d2dfd2a760935128c37fc4704800 (diff)
downloadslackbuilds-775b1977842ef7279d55bcab86accc2b10ef037a.tar.xz
network/dillo: Updated for version 3.1.0.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'network')
-rw-r--r--network/dillo/README19
-rw-r--r--network/dillo/dillo-3.0.5-fno-common.patch100
-rw-r--r--network/dillo/dillo-3.0.5-openssl-1.1.patch26
-rw-r--r--network/dillo/dillo.SlackBuild25
-rw-r--r--network/dillo/dillo.info8
-rw-r--r--network/dillo/doinst.sh6
-rw-r--r--network/dillo/slack-desc10
7 files changed, 39 insertions, 155 deletions
diff --git a/network/dillo/README b/network/dillo/README
index 90dd6b4156..e90e142ddb 100644
--- a/network/dillo/README
+++ b/network/dillo/README
@@ -1,6 +1,13 @@
-Dillo is a multi-platform graphical web browser known for its speed
-and small footprint. It is written in C and C++ and is based on FLTK.
-
-HTTPS and SSL support is built into this but is only at *alpha*
-stage. It can be commented out in the dillo.SlackBuild file if you
-wish.
+Dillo is a fast and small graphical web browser with the following
+features:
+Multi-platform, running on Linux, BSD, MacOS, Windows (via Cygwin),
+and even Atari.
+Written in C and C++ with few dependencies.
+Implements its own real-time rendering engine.
+Low memory usage and fast rendering, even with large pages.
+Uses the fast and bloat-free FLTK GUI library.
+Support for HTTP, HTTPS, FTP and local files.
+Extensible with plugins written in any language (see the list of
+plugins).
+Is free software licensed with the GPLv3.
+Does *NOT* support JavaScript.
diff --git a/network/dillo/dillo-3.0.5-fno-common.patch b/network/dillo/dillo-3.0.5-fno-common.patch
deleted file mode 100644
index df80f55afa..0000000000
--- a/network/dillo/dillo-3.0.5-fno-common.patch
+++ /dev/null
@@ -1,100 +0,0 @@
---- a/dpid/dpid.c
-+++ b/dpid/dpid.c
-@@ -41,6 +41,26 @@
- volatile sig_atomic_t caught_sigchld = 0;
- char *SharedKey = NULL;
-
-+char *srs_name;
-+
-+/*! dpid's service request socket file descriptor */
-+int srs_fd;
-+
-+/*! Number of available plugins */
-+int numdpis;
-+
-+/*! Number of sockets being watched */
-+int numsocks;
-+
-+/*! State information for each plugin. */
-+struct dp *dpi_attr_list;
-+
-+/*! service served for each plugin */
-+Dlist *services_list;
-+
-+/*! Set of sockets watched for connections */
-+fd_set sock_set;
-+
- /*! Remove dpid_comm_keys file.
- * This avoids that dillo instances connect to a stale port after dpid
- * has exited (e.g. after a reboot).
---- a/dpid/dpid.h
-+++ b/dpid/dpid.h
-@@ -25,10 +25,10 @@
-
- /*! \TODO: Should read this from dillorc */
- #define SRS_NAME "dpid.srs"
--char *srs_name;
-+extern char *srs_name;
-
- /*! dpid's service request socket file descriptor */
--int srs_fd;
-+extern int srs_fd;
-
- /*! plugin state information
- */
-@@ -49,19 +49,19 @@
- };
-
- /*! Number of available plugins */
--int numdpis;
-+extern int numdpis;
-
- /*! Number of sockets being watched */
--int numsocks;
-+extern int numsocks;
-
- /*! State information for each plugin. */
--struct dp *dpi_attr_list;
-+extern struct dp *dpi_attr_list;
-
- /*! service served for each plugin */
--Dlist *services_list;
-+extern Dlist *services_list;
-
- /*! Set of sockets watched for connections */
--fd_set sock_set;
-+extern fd_set sock_set;
-
- /*! Set to 1 by the SIGCHLD handler dpi_sigchld */
- extern volatile sig_atomic_t caught_sigchld;
---- a/dpid/dpid_common.c
-+++ b/dpid/dpid_common.c
-@@ -14,6 +14,9 @@
- #include <unistd.h>
- #include "dpid_common.h"
-
-+/*! Error codes for dpid */
-+dpi_errno_t dpi_errno;
-+
- /*
- * Send a verbose error message.
- */
---- a/dpid/dpid_common.h
-+++ b/dpid/dpid_common.h
-@@ -35,12 +35,13 @@
- #define CKD_WRITE(fd, msg) ckd_write(fd, msg, __FILE__, __LINE__)
- #define CKD_CLOSE(fd) ckd_close(fd, __FILE__, __LINE__)
-
--
- /*! Error codes for dpid */
--enum {
-+typedef enum {
- no_errors,
- dpid_srs_addrinuse /* dpid service request socket address already in use */
--} dpi_errno;
-+} dpi_errno_t;
-+
-+extern dpi_errno_t dpi_errno;
-
- /*! Intended for identifying dillo plugins
- * and related files
diff --git a/network/dillo/dillo-3.0.5-openssl-1.1.patch b/network/dillo/dillo-3.0.5-openssl-1.1.patch
deleted file mode 100644
index f21694113c..0000000000
--- a/network/dillo/dillo-3.0.5-openssl-1.1.patch
+++ /dev/null
@@ -1,26 +0,0 @@
---- a/configure.ac
-+++ b/configure.ac
-@@ -286,7 +286,7 @@
-
- if test "x$ssl_ok" = "xyes"; then
- old_libs="$LIBS"
-- AC_CHECK_LIB(ssl, SSL_library_init, ssl_ok=yes, ssl_ok=no, -lcrypto)
-+ AC_CHECK_LIB(ssl, OPENSSL_config, ssl_ok=yes, ssl_ok=no, -lcrypto)
- LIBS="$old_libs"
- fi
-
---- a/dpi/https.c
-+++ b/dpi/https.c
-@@ -476,7 +476,11 @@
- case X509_V_ERR_DEPTH_ZERO_SELF_SIGNED_CERT:
- /*Either self signed and untrusted*/
- /*Extract CN from certificate name information*/
-+#if OPENSSL_VERSION_NUMBER < 0x10100000L
- if ((cn = strstr(remote_cert->name, "/CN=")) == NULL) {
-+#else
-+ if ((cn = strstr(X509_get_subject_name(remote_cert), "/CN=")) == NULL) {
-+#endif
- strcpy(buf, "(no CN given)");
- } else {
- char *cn_end;
-
diff --git a/network/dillo/dillo.SlackBuild b/network/dillo/dillo.SlackBuild
index 5094bd6ec7..2e1589f596 100644
--- a/network/dillo/dillo.SlackBuild
+++ b/network/dillo/dillo.SlackBuild
@@ -1,10 +1,12 @@
#!/bin/bash
-# Slackware build script for dillo. It has NOT been tested on x86_64.
+# Slackware build script for dillo web browser.
# Copyright 2012 John B TN, USA
# This was only successful with the help of ErikHanson@slackbuilds.org and
# B Watson who e-mailed me his patch/idea for the fltk and fltk-13 problem
+# I was having during the 3.0.5 build.
+#
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -27,7 +29,7 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=dillo
-VERSION=${VERSION:-3.0.5}
+VERSION=${VERSION:-3.1.0}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -40,14 +42,13 @@ if [ -z "$ARCH" ]; then
esac
fi
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
fi
+NUMJOBS=${NUMJOBS:-" -j $(expr $(nproc) + 1) "}
+
TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
@@ -81,19 +82,15 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-# Thanks gentoo!
-patch -p1 < $CWD/dillo-3.0.5-openssl-1.1.patch
-patch -p1 < $CWD/dillo-3.0.5-fno-common.patch
-
autoreconf -fi
-#https and ssl are in the alpha stage, but if you don't want to try and use it
-#just delete or comment out --enable-ssl
-
+# Dillo looks for openssl first, then tls. Both are still in alpha
+# stage but work to a degree and are better than nothing.
CFLAGS="$SLKCFLAGS" \
CXXFLAGS="$SLKCFLAGS" \
./configure \
- --enable-ssl \
+ --enable-openssl \
+ --enable-tls \
--prefix=/usr \
--sysconfdir=/etc \
--localstatedir=/var \
@@ -113,7 +110,7 @@ find $PKG/usr/man -type f -exec gzip -9 {} \;
for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a README AUTHORS INSTALL COPYING $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a README AUTHORS COPYING $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install
diff --git a/network/dillo/dillo.info b/network/dillo/dillo.info
index f1ab0ad06c..ab11e672ad 100644
--- a/network/dillo/dillo.info
+++ b/network/dillo/dillo.info
@@ -1,8 +1,8 @@
PRGNAM="dillo"
-VERSION="3.0.5"
-HOMEPAGE="https://www.dillo.org/"
-DOWNLOAD="https://www.dillo.org/download/dillo-3.0.5.tar.bz2"
-MD5SUM="554aad93b6107bba696f4da022c41561"
+VERSION="3.1.0"
+HOMEPAGE="https://dillo-browser.github.io/"
+DOWNLOAD="https://github.com/dillo-browser/dillo/releases/download/v3.1.0/dillo-3.1.0.tar.bz2"
+MD5SUM="54e09a5282edc4fa59ff99720461fc57"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES="fltk"
diff --git a/network/dillo/doinst.sh b/network/dillo/doinst.sh
index 0d18ec2ded..a189943dd8 100644
--- a/network/dillo/doinst.sh
+++ b/network/dillo/doinst.sh
@@ -19,3 +19,9 @@ if [ -x /usr/bin/update-desktop-database ]; then
/usr/bin/update-desktop-database -q usr/share/applications >/dev/null 2>&1
fi
+if [ -e usr/share/icons/hicolor/icon-theme.cache ]; then
+ if [ -x /usr/bin/gtk-update-icon-cache ]; then
+ /usr/bin/gtk-update-icon-cache -f usr/share/icons/hicolor >/dev/null 2>&1
+ fi
+fi
+
diff --git a/network/dillo/slack-desc b/network/dillo/slack-desc
index 74d7f3befc..443a5c371d 100644
--- a/network/dillo/slack-desc
+++ b/network/dillo/slack-desc
@@ -8,12 +8,12 @@
|-----handy-ruler------------------------------------------------------|
dillo: dillo (dillo web browser)
dillo:
-dillo: Dillo is a multi-platform graphical web browser known
-dillo: for its speed and small footprint. It is written in C and
-dillo: C++ and is based on FLTK. Dillo is free software made
-dillo: available under the terms of the GNU GPLv3.
+dillo: Dillo is a multi-platform graphical web browser, known for its
+dillo: its speed and small footprint, that is developed with a focus
+dillo: on personal security and privacy. It is built with the FLTK 1.3
+dillo: GUI toolkit. Dillo is free GPL-3.0 licensed software.
dillo:
-dillo: Homepage: http://www.dillo.org
+dillo: Homepage: https://dillo-browser.github.io/
dillo:
dillo:
dillo: