aboutsummaryrefslogtreecommitdiff
path: root/network/gns3/gns3.SlackBuild
diff options
context:
space:
mode:
authorAlam Guntur Nugroho <alamgn@mail.ugm.ac.id>2010-05-12 23:32:11 +0200
committerRobby Workman <rworkman@slackbuilds.org>2010-05-12 23:32:11 +0200
commita69eff4bed983d39341ce26f06b192034b703f2a (patch)
tree48ec89e165cec187f6b457960530df46fdf95c8b /network/gns3/gns3.SlackBuild
parent45728f38d448465622702a671a70fcecbac5b321 (diff)
downloadslackbuilds-a69eff4bed983d39341ce26f06b192034b703f2a.tar.xz
network/gns3: Added to 12.2 repository
Diffstat (limited to 'network/gns3/gns3.SlackBuild')
-rw-r--r--network/gns3/gns3.SlackBuild79
1 files changed, 79 insertions, 0 deletions
diff --git a/network/gns3/gns3.SlackBuild b/network/gns3/gns3.SlackBuild
new file mode 100644
index 000000000000..a0038d77c85a
--- /dev/null
+++ b/network/gns3/gns3.SlackBuild
@@ -0,0 +1,79 @@
+#!/bin/sh
+
+# Slackware build script for gns3 (http://www.gns3.net)
+
+# Copyright 2008 Alam Guntur Nugroho (alamgn@mail.ugm.ac.id)
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=gns3
+VERSION=${VERSION:-0.6}
+ARCH=noarch
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf GNS3-$VERSION-src
+tar xvf $CWD/GNS3-$VERSION-src.tar.bz2
+cd GNS3-$VERSION-src
+chown -R root:root .
+chmod -R u+w,go+r-w,a-s .
+
+python setup.py install --root=$PKG
+
+mkdir -p $PKG/usr/man/man1
+gzip -9c docs/man/gns3.1 > $PKG/usr/man/man1/gns3.1.gz
+
+# Create a desktop menu entry with an icon
+mkdir -p $PKG/usr/share/{applications,pixmaps}
+cat << EOF > $PKG/usr/share/applications/$PRGNAM.desktop
+[Desktop Entry]
+Type=Application
+Name=GNS3
+GenericName=Graphical Network Simulator
+Comment=GNS3 is a graphical network simulator that allows simulation of complex networks.
+Icon=gns3
+Exec=gns3
+Terminal=false
+Categories=Qt;System;
+StartupNotify=true
+EOF
+cat $CWD/$PRGNAM.png > $PKG/usr/share/pixmaps/$PRGNAM.png
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a \
+ AUTHORS CHANGELOG LICENSE README TODO \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+find $PKG/usr/doc -type f -exec chmod 0644 {} \;
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-${BUILD}${TAG}.tgz