aboutsummaryrefslogtreecommitdiff
path: root/multimedia
diff options
context:
space:
mode:
authorGianluca Pernigotto <jeanlucperni@gmail.com>2024-01-18 07:48:56 +0700
committerWilly Sudiarto Raharjo <willysr@slackbuilds.org>2024-01-18 08:56:57 +0700
commit71ae6d23419175406131f5b0257d8bec901591ab (patch)
tree4cdf3e7a87c8c39c0d0df1fdb916e7c11b323c39 /multimedia
parent7975fa56e7f3bd917595432ab1109b1d37e66869 (diff)
downloadslackbuilds-71ae6d23419175406131f5b0257d8bec901591ab.tar.xz
multimedia/videomass: Added (GUI for ffmpeg).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'multimedia')
-rw-r--r--multimedia/videomass/README8
-rw-r--r--multimedia/videomass/doinst.sh11
-rw-r--r--multimedia/videomass/slack-desc19
-rw-r--r--multimedia/videomass/videomass.SlackBuild102
-rw-r--r--multimedia/videomass/videomass.info10
5 files changed, 150 insertions, 0 deletions
diff --git a/multimedia/videomass/README b/multimedia/videomass/README
new file mode 100644
index 000000000000..69d12a051338
--- /dev/null
+++ b/multimedia/videomass/README
@@ -0,0 +1,8 @@
+Videomass is a powerful, multitasking and cross-platform graphical user
+interface (GUI) for FFmpeg and yt-dlp. It offers a wide range of
+features and functions, making it a comprehensive software solution.
+
+Videomass is Free (libre) Software, created and maintained by Gianluca
+(jeanslack) Pernigotto; it was written in Python3 using the wxPython4
+toolkit; it is cross-platform and works on Linux, MacOs, Windows and
+FreeBSD.
diff --git a/multimedia/videomass/doinst.sh b/multimedia/videomass/doinst.sh
new file mode 100644
index 000000000000..5a0b8c86f3cc
--- /dev/null
+++ b/multimedia/videomass/doinst.sh
@@ -0,0 +1,11 @@
+if [ -x /usr/bin/update-desktop-database ]; then
+ usr/bin/update-desktop-database -q usr/share/applications >/dev/null 2>&1
+fi
+if [ -x /usr/bin/update-mime-database ]; then
+ usr/bin/update-mime-database usr/share/mime >/dev/null 2>&1
+fi
+if [ -e usr/share/icons/hicolor/icon-theme.cache ]; then
+ if [ -x /usr/bin/gtk-update-icon-cache ]; then
+ /usr/bin/gtk-update-icon-cache -f usr/share/icons/hicolor >/dev/null 2>&1
+ fi
+fi
diff --git a/multimedia/videomass/slack-desc b/multimedia/videomass/slack-desc
new file mode 100644
index 000000000000..854e071dd7e1
--- /dev/null
+++ b/multimedia/videomass/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+videomass: videomass (GUI for FFmpeg and yt-dlp)
+videomass:
+videomass: Videomass is a free, open source and cross-platform GUI for FFmpeg
+videomass: and yt-dlp written in wxPython.
+videomass:
+videomass:
+videomass: Homepage: http://jeanslack.github.io/Videomass/
+videomass:
+videomass:
+videomass:
+videomass:
diff --git a/multimedia/videomass/videomass.SlackBuild b/multimedia/videomass/videomass.SlackBuild
new file mode 100644
index 000000000000..a46b18c06c46
--- /dev/null
+++ b/multimedia/videomass/videomass.SlackBuild
@@ -0,0 +1,102 @@
+#!/bin/bash
+
+# Slackware build script for videomass
+
+# Copyright 2024 Gianluca Pernigotto Verona, Italy
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+cd $(dirname $0) ; CWD=$(pwd)
+
+PRGNAM=videomass
+VERSION=${VERSION:-5.0.3}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
+
+SRCNAM=Videomass
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
+# the name of the created package would be, and then exit. This information
+# could be useful to other scripts.
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $SRCNAM-$VERSION
+tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
+cd $SRCNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python3 setup.py install --root=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mv $PKG/usr/share/man $PKG/usr/man
+find $PKG/usr/man -type f -exec gzip -9 {} \;
+for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a README.md LICENSE TODO CHANGELOG $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+cat $CWD/doinst.sh > $PKG/install/doinst.sh
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/multimedia/videomass/videomass.info b/multimedia/videomass/videomass.info
new file mode 100644
index 000000000000..980f4d6e0a31
--- /dev/null
+++ b/multimedia/videomass/videomass.info
@@ -0,0 +1,10 @@
+PRGNAM="videomass"
+VERSION="5.0.3"
+HOMEPAGE="http://jeanslack.github.io/Videomass/"
+DOWNLOAD="https://github.com/jeanslack/Videomass/archive/v5.0.3/Videomass-5.0.3.tar.gz"
+MD5SUM="ae626ffdf37815b51db0524a9363a225"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="wxPython4 python3-pubsub yt-dlp"
+MAINTAINER="Gianluca Pernigotto"
+EMAIL="jeanlucperni@gmail.com"