aboutsummaryrefslogtreecommitdiff
path: root/libraries
diff options
context:
space:
mode:
authorWilly Sudiarto Raharjo <willysr@slackbuilds.org>2021-11-25 09:53:57 +0700
committerWilly Sudiarto Raharjo <willysr@slackbuilds.org>2021-11-25 09:53:57 +0700
commitfff2bcf3f0bc4af3d7c63e3d78ac460c8fff5a5a (patch)
tree7a10a9bf4f9b14d39028d201e0f2540eb13242d0 /libraries
parentc240b083530e896cdc24bafdc6c458516c4c32b4 (diff)
libraries/python2-PyYAML: Renamed from PyYAML.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'libraries')
-rw-r--r--libraries/PyYAML/slack-desc19
-rw-r--r--libraries/python2-PyYAML/README (renamed from libraries/PyYAML/README)0
-rw-r--r--libraries/python2-PyYAML/python2-PyYAML.SlackBuild (renamed from libraries/PyYAML/PyYAML.SlackBuild)13
-rw-r--r--libraries/python2-PyYAML/python2-PyYAML.info (renamed from libraries/PyYAML/PyYAML.info)2
-rw-r--r--libraries/python2-PyYAML/slack-desc19
5 files changed, 27 insertions, 26 deletions
diff --git a/libraries/PyYAML/slack-desc b/libraries/PyYAML/slack-desc
deleted file mode 100644
index 99aea3424d18..000000000000
--- a/libraries/PyYAML/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-PyYAML: PyYAML (YAML parser and emitter for Python)
-PyYAML:
-PyYAML: YAML is a data serialization format designed for human readability
-PyYAML: and interaction with scripting languages. PyYAML is a YAML parser
-PyYAML: and emitter for Python.
-PyYAML:
-PyYAML: Homepage: https://pyyaml.org/
-PyYAML:
-PyYAML:
-PyYAML:
-PyYAML:
diff --git a/libraries/PyYAML/README b/libraries/python2-PyYAML/README
index 2bede18e0f19..2bede18e0f19 100644
--- a/libraries/PyYAML/README
+++ b/libraries/python2-PyYAML/README
diff --git a/libraries/PyYAML/PyYAML.SlackBuild b/libraries/python2-PyYAML/python2-PyYAML.SlackBuild
index 19c6fdee6588..162e9a1d7f34 100644
--- a/libraries/PyYAML/PyYAML.SlackBuild
+++ b/libraries/python2-PyYAML/python2-PyYAML.SlackBuild
@@ -1,6 +1,6 @@
#!/bin/bash
-# Slackware build script for PyYAML
+# Slackware build script for python2-PyYAML
# Copyright 2010-2019 David Woodfall <dave@slackbuilds.org>
# All rights reserved.
#
@@ -23,7 +23,8 @@
cd $(dirname $0) ; CWD=$(pwd)
-PRGNAM=PyYAML
+PRGNAM=python2-PyYAML
+SRCNAM=PyYAML
VERSION=${VERSION:-3.13}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -68,9 +69,9 @@ set -e
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
-rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
-cd $PRGNAM-$VERSION
+rm -rf $SRCNAM-$VERSION
+tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
+cd $SRCNAM-$VERSION
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
@@ -78,7 +79,7 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python setup.py install --root=$PKG
+python2 setup.py install --root=$PKG
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
diff --git a/libraries/PyYAML/PyYAML.info b/libraries/python2-PyYAML/python2-PyYAML.info
index 62b6c3f6d8fd..2d54192c1e8b 100644
--- a/libraries/PyYAML/PyYAML.info
+++ b/libraries/python2-PyYAML/python2-PyYAML.info
@@ -1,4 +1,4 @@
-PRGNAM="PyYAML"
+PRGNAM="python2-PyYAML"
VERSION="3.13"
HOMEPAGE="https://pyyaml.org/"
DOWNLOAD="https://pyyaml.org/download/pyyaml/PyYAML-3.13.tar.gz"
diff --git a/libraries/python2-PyYAML/slack-desc b/libraries/python2-PyYAML/slack-desc
new file mode 100644
index 000000000000..19aefcbc0489
--- /dev/null
+++ b/libraries/python2-PyYAML/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+python2-PyYAML: python2-PyYAML (YAML parser and emitter for Python)
+python2-PyYAML:
+python2-PyYAML: YAML is a data serialization format designed for human readability
+python2-PyYAML: and interaction with scripting languages. PyYAML is a YAML parser
+python2-PyYAML: and emitter for Python.
+python2-PyYAML:
+python2-PyYAML: Homepage: https://pyyaml.org/
+python2-PyYAML:
+python2-PyYAML:
+python2-PyYAML:
+python2-PyYAML: