aboutsummaryrefslogtreecommitdiff
path: root/libraries
diff options
context:
space:
mode:
authorB. Watson <urchlay@slackware.uk>2024-10-20 02:45:34 -0400
committerWilly Sudiarto Raharjo <willysr@slackbuilds.org>2024-11-02 19:28:36 +0700
commitf1d235882819fe06536fa7d4bab7ce39f5ea3448 (patch)
tree43eaf7230526c240a9e7b52722e94b9fafeb57a0 /libraries
parent67d2cd87c92db581cf0aa37532ae03e597923999 (diff)
libraries/tolua++: Build with lua51.
Signed-off-by: B. Watson <urchlay@slackware.uk> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'libraries')
-rw-r--r--libraries/tolua++/tolua++.SlackBuild17
-rw-r--r--libraries/tolua++/tolua++.info2
2 files changed, 12 insertions, 7 deletions
diff --git a/libraries/tolua++/tolua++.SlackBuild b/libraries/tolua++/tolua++.SlackBuild
index b04d61d39120..446593369ca2 100644
--- a/libraries/tolua++/tolua++.SlackBuild
+++ b/libraries/tolua++/tolua++.SlackBuild
@@ -23,6 +23,8 @@
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+# 20241020 bkw: Modified by SlackBuilds.org, BUILD=3: build with lua51.
+
# 20220424 bkw: Modified by SlackBuilds.org, BUILD=2:
# - fix doc permissions.
@@ -75,26 +77,29 @@ rm -rf $SRCNAM-$VERSION
tar xvf $CWD/$SRCNAM-$VERSION.tar.?z*
cd $SRCNAM-$VERSION
chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \+ -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \+
+find -L . -perm /111 -a \! -perm 755 -a -exec chmod 755 {} \+ -o \
+ \! -perm /111 -a \! -perm 644 -a -exec chmod 644 {} \+
# Fix library directory, library and executable name, version info.
sed -i "s|INSTALL_LIB\ lib|INSTALL_LIB lib${LIBDIRSUFFIX}|" cmake/dist.cmake || exit 1
sed -i "s|\ toluapp\ | tolua++ |" CMakeLists.txt || exit 1
sed -i "s|\"${PRGNAM}-1.0.92\"|\"${PRGNAM}-${VERSION}\"|" include/tolua++.h || exit 1
+# 20241020 bkw: this won't build with lua > 5.1, so tell cmake to only
+# look for that version. Also have to force the include dir, below, to
+# keep it from finding lua 5.4's /usr/include/lua.h
+sed -i '/find_package/s,Lua,Lua51,' CMakeLists.txt
+
mkdir -p build
cd build
cmake \
-DCMAKE_C_FLAGS:STRING="$SLKCFLAGS" \
-DCMAKE_CXX_FLAGS:STRING="$SLKCFLAGS" \
+ -DLUA_INCLUDE_DIR=/usr/include/lua5.1 \
-DCMAKE_INSTALL_PREFIX=/usr \
-DMAN_INSTALL_DIR=/usr/man \
-DCMAKE_BUILD_TYPE=Release ..
- make
+ make VERBOSE=1
make install/strip DESTDIR=$PKG
cd ..
diff --git a/libraries/tolua++/tolua++.info b/libraries/tolua++/tolua++.info
index 256e37b9c743..07a38c040314 100644
--- a/libraries/tolua++/tolua++.info
+++ b/libraries/tolua++/tolua++.info
@@ -5,6 +5,6 @@ DOWNLOAD="https://github.com/LuaDist/toluapp/archive/1.0.93/toluapp-1.0.93.tar.g
MD5SUM="689d952034e55d4333fa240f7516e68a"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
-REQUIRES="lua"
+REQUIRES="lua51"
MAINTAINER="Matteo Bernardini"
EMAIL="ponce@slackbuilds.org"