aboutsummaryrefslogtreecommitdiff
path: root/libraries/vmaf
diff options
context:
space:
mode:
authorVijay Marcel <vijaymarcel@outlook.com>2022-08-31 04:12:06 +0100
committerWilly Sudiarto Raharjo <willysr@slackbuilds.org>2022-09-03 17:58:43 +0700
commit5e6646d3feac1d7724997a4f9b881e087f9f704a (patch)
treeb842caf5e6f57bc914075b4ca13e9705990ca5cd /libraries/vmaf
parentb992d1e8636bcd11ad784af9127d085377887adc (diff)
downloadslackbuilds-5e6646d3feac1d7724997a4f9b881e087f9f704a.tar.xz
libraries/vmaf: Added (Video Multi Method Assessment Fusion)
Signed-off-by: Dave Woodfall <dave@slackbuilds.org> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'libraries/vmaf')
-rw-r--r--libraries/vmaf/README7
-rw-r--r--libraries/vmaf/slack-desc19
-rw-r--r--libraries/vmaf/vmaf.SlackBuild122
-rw-r--r--libraries/vmaf/vmaf.info10
4 files changed, 158 insertions, 0 deletions
diff --git a/libraries/vmaf/README b/libraries/vmaf/README
new file mode 100644
index 000000000000..fbd22db11aad
--- /dev/null
+++ b/libraries/vmaf/README
@@ -0,0 +1,7 @@
+VMAF is a perceptual video quality assessment algorithm
+developed by NetFlix. This software includes a standalone C
+library libvmaf and its wrapping python library. The python
+also provides a set of tools that allows user to train and test
+a custom VMAF model.
+
+This is an optional dependency for FFmpeg.
diff --git a/libraries/vmaf/slack-desc b/libraries/vmaf/slack-desc
new file mode 100644
index 000000000000..e3c9e0699323
--- /dev/null
+++ b/libraries/vmaf/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+vmaf: vmaf (Video Multi Method Assessment Fusion)
+vmaf:
+vmaf: VMAF is a perceptual video quality assessment algorithm
+vmaf: developed by Netflix.It includes a standalone C library
+vmaf: libvmaf and its wrapping python library. The python library
+vmaf: also provides a set of tools that allows user to train and
+vmaf: test custom VMAF models.
+vmaf:
+vmaf: Homepage: https://github.com/Netflix/vmaf
+vmaf:
+vmaf:
diff --git a/libraries/vmaf/vmaf.SlackBuild b/libraries/vmaf/vmaf.SlackBuild
new file mode 100644
index 000000000000..0b83fbad263a
--- /dev/null
+++ b/libraries/vmaf/vmaf.SlackBuild
@@ -0,0 +1,122 @@
+#!/bin/bash
+
+# Slackware build script for vmaf
+
+# Copyright 2022 Vijay Marcel
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+cd $(dirname $0) ; CWD=$(pwd)
+
+PRGNAM=vmaf
+VERSION=${VERSION:-2.3.1}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
+# the name of the created package would be, and then exit. This information
+# could be useful to other scripts.
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
+set -e
+trap 'echo "$0 FAILED at line $LINENO!" | tee -a $OUTPUT/error-${PRGNAM}.log' ERR
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+mkdir -pv $TMP/$PRGNAM-$VERSION/libvmaf/build
+
+cd third_party/libsvm && make lib
+
+cd $TMP/$PRGNAM-$VERSION/
+
+meson setup libvmaf/build libvmaf --buildtype release --prefix=/usr --libdir=/usr/lib${LIBDIRSUFFIX} -Denable_float=true && \
+
+ninja -v -C libvmaf/build
+
+ninja -v -C libvmaf/build test
+
+cd $TMP/$PRGNAM-$VERSION/python && python3 setup.py build_ext --build-lib .
+
+DESTDIR=$PKG ninja -v -C $TMP/$PRGNAM-$VERSION/libvmaf/build install
+
+install -D -m755 $TMP/$PRGNAM-$VERSION/libvmaf/build/tools/vmafossexec -t "$PKG/usr/bin/"
+
+mkdir -pv $PKG/usr/share/$PRGNAM-$VERSION
+
+cp -dr --no-preserve='ownership' $TMP/$PRGNAM-$VERSION/model "$PKG/usr/share/$PRGNAM-$VERSION/"
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" |
+ grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+# Don't ship .la files:
+rm -f $PKG/{,usr/}lib${LIBDIRSUFFIX}/*.la
+
+cd $TMP/$PRGNAM-$VERSION
+
+mkdir -pv $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a CHANGELOG.md LICENSE README.md $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -pv $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/libraries/vmaf/vmaf.info b/libraries/vmaf/vmaf.info
new file mode 100644
index 000000000000..7562cb35477e
--- /dev/null
+++ b/libraries/vmaf/vmaf.info
@@ -0,0 +1,10 @@
+PRGNAM="vmaf"
+VERSION="2.3.1"
+HOMEPAGE="https://github.com/Netflix/vmaf/"
+DOWNLOAD="https://github.com/Netflix/vmaf/archive/v2.3.1/vmaf-2.3.1.tar.gz"
+MD5SUM="be40a256a3b739ffc2119b45f919d6bf"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="OpenBLAS numpy3"
+MAINTAINER="Vijay Marcel"
+EMAIL="vijaymarcel@outlook.com"