aboutsummaryrefslogtreecommitdiff
path: root/libraries/pyquery
diff options
context:
space:
mode:
authorRobby Workman <rworkman@slackbuilds.org>2011-03-16 01:13:49 -0500
committerRobby Workman <rworkman@slackbuilds.org>2011-03-20 12:33:01 -0500
commit7a1b4848a3d34a263544fadf08178c91c12fbad0 (patch)
tree8987d0fc908e371dfa87445425f59c7514075b37 /libraries/pyquery
parent987d45e99a299c3b24418b2976e8ec9d5f3bf404 (diff)
downloadslackbuilds-7a1b4848a3d34a263544fadf08178c91c12fbad0.tar.xz
python/*: Moved a lot of Python stuff here
The criteria for whether something "belongs" in Development or Libraries or Python or ... is admittedly arbitrary. As a general rule, if it could be either Libraries or Python, it's Python. Otherwise, pick one and we'll go from there... Signed-off-by: Robby Workman <rworkman@slackbuilds.org>
Diffstat (limited to 'libraries/pyquery')
-rw-r--r--libraries/pyquery/README12
-rw-r--r--libraries/pyquery/pyquery.SlackBuild50
-rw-r--r--libraries/pyquery/pyquery.info10
-rw-r--r--libraries/pyquery/slack-desc19
4 files changed, 0 insertions, 91 deletions
diff --git a/libraries/pyquery/README b/libraries/pyquery/README
deleted file mode 100644
index cc2788340c9e..000000000000
--- a/libraries/pyquery/README
+++ /dev/null
@@ -1,12 +0,0 @@
-pyquery (a jquery-like library for python)
-
-pyquery allows you to make jquery queries on xml documents. The API is
-as much as possible the similar to jquery. pyquery uses lxml for fast
-xml and html manipulation.
-
-It can be used for many purposes, one idea that I might try in the
-future is to use it for templating with pure http templates that you
-modify using pyquery. I can also be used for web scrapping or for
-theming applications.
-
-Requires lxml.
diff --git a/libraries/pyquery/pyquery.SlackBuild b/libraries/pyquery/pyquery.SlackBuild
deleted file mode 100644
index 5284aaedcf89..000000000000
--- a/libraries/pyquery/pyquery.SlackBuild
+++ /dev/null
@@ -1,50 +0,0 @@
-#!/bin/sh
-
-# Slackware build script for pyquery
-# Written by Šime Ramov <s@ramov.com>
-
-PRGNAM=pyquery
-VERSION=${VERSION:-0.6.1}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i486 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-CWD=$(pwd)
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $PRGNAM-$VERSION
-tar xzf $CWD/$PRGNAM-$VERSION.tar.gz
-cd $PRGNAM-$VERSION
-chown -R root:root .
-find . \
- \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
- -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \;
-
-python setup.py build
-python setup.py install --root=$PKG
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a README.txt CHANGES.txt $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/libraries/pyquery/pyquery.info b/libraries/pyquery/pyquery.info
deleted file mode 100644
index 366e28f508af..000000000000
--- a/libraries/pyquery/pyquery.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="pyquery"
-VERSION="0.6.1"
-HOMEPAGE="http://www.bitbucket.org/olauzanne/pyquery/"
-DOWNLOAD="http://pypi.python.org/packages/source/p/pyquery/pyquery-0.6.1.tar.gz"
-MD5SUM="2a677d7c52b1aa89f5aaa70427e36b70"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-MAINTAINER="Šime Ramov"
-EMAIL="s@ramov.com"
-APPROVED="Erik Hanson"
diff --git a/libraries/pyquery/slack-desc b/libraries/pyquery/slack-desc
deleted file mode 100644
index e5905e99028d..000000000000
--- a/libraries/pyquery/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description. Line
-# up the first '|' above the ':' following the base package name, and the '|'
-# on the right side marks the last column you can put a character in. You must
-# make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':'.
-
- |-----handy-ruler------------------------------------------------------|
-pyquery: pyquery (a jquery-like library for python)
-pyquery:
-pyquery: pyquery allows you to make jquery queries on xml documents. The API
-pyquery: is as much as possible the similar to jquery. pyquery uses lxml for
-pyquery: fast xml and html manipulation.
-pyquery:
-pyquery: It can be used for many purposes, one idea that I might try in the
-pyquery: future is to use it for templating with pure http templates that you
-pyquery: modify using pyquery. I can also be used for web scrapping or for
-pyquery: theming applications.
-pyquery: