aboutsummaryrefslogtreecommitdiff
path: root/libraries/pyPEG2/pyPEG2.SlackBuild
diff options
context:
space:
mode:
authorMatteo Bernardini <ponce@slackbuilds.org>2022-02-05 18:53:17 +0100
committerWilly Sudiarto Raharjo <willysr@slackbuilds.org>2022-02-06 15:47:06 +0700
commit145bf7a38cbf9f69533d10216bcbe2c9f2faea2a (patch)
treed250cbc17dec08b21866eaf8b5e9e9785813a249 /libraries/pyPEG2/pyPEG2.SlackBuild
parent4139712fe9c3356de0471c85cd4977a9acb54a33 (diff)
downloadslackbuilds-145bf7a38cbf9f69533d10216bcbe2c9f2faea2a.tar.xz
libraries/pyPEG2: Updated for version 20211118_4dd9d69.
Signed-off-by: Matteo Bernardini <ponce@slackbuilds.org> Signed-off-by: Andrew Clemons <andrew.clemons@gmail.com> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'libraries/pyPEG2/pyPEG2.SlackBuild')
-rw-r--r--libraries/pyPEG2/pyPEG2.SlackBuild16
1 files changed, 9 insertions, 7 deletions
diff --git a/libraries/pyPEG2/pyPEG2.SlackBuild b/libraries/pyPEG2/pyPEG2.SlackBuild
index 13fd1ec8214b..d3abe4d92b5d 100644
--- a/libraries/pyPEG2/pyPEG2.SlackBuild
+++ b/libraries/pyPEG2/pyPEG2.SlackBuild
@@ -25,7 +25,7 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=pyPEG2
-VERSION=${VERSION:-2.15.2}
+VERSION=${VERSION:-20211118_4dd9d69}
BUILD=${BUILD:-4}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -38,6 +38,8 @@ if [ -z "$ARCH" ]; then
esac
fi
+SRCNAM=pypeg2
+
# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
# the name of the created package would be, and then exit. This information
# could be useful to other scripts.
@@ -69,9 +71,9 @@ set -e
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
-rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM.tar.gz
-cd $PRGNAM-$VERSION
+rm -rf $SRCNAM-$VERSION
+tar xvf $CWD/$SRCNAM-$VERSION.tar.?z
+cd $SRCNAM-$VERSION
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
@@ -82,8 +84,8 @@ find -L . \
python setup.py build
python setup.py install --root=$PKG
-# Build pyPEG2 with python3. Default is no.
-if [ "${PYTHON3:-no}" == "yes" ]; then
+# Build pyPEG2 with python3. Default is yes.
+if [ "${PYTHON3:-yes}" == "yes" ]; then
python3 setup.py build
python3 setup.py install --root=$PKG
fi
@@ -92,7 +94,7 @@ find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | gr
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp CHANGES.txt LICENSE.txt PKG-INFO README.txt TODO.txt $PKG/usr/doc/$PRGNAM-$VERSION
+cp CHANGES.txt LICENSE.txt README.md TODO.txt $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install