aboutsummaryrefslogtreecommitdiff
path: root/libraries/pyOpenSSL
diff options
context:
space:
mode:
authorRobby Workman <rworkman@slackbuilds.org>2011-03-16 01:13:49 -0500
committerRobby Workman <rworkman@slackbuilds.org>2011-03-20 12:33:01 -0500
commit7a1b4848a3d34a263544fadf08178c91c12fbad0 (patch)
tree8987d0fc908e371dfa87445425f59c7514075b37 /libraries/pyOpenSSL
parent987d45e99a299c3b24418b2976e8ec9d5f3bf404 (diff)
downloadslackbuilds-7a1b4848a3d34a263544fadf08178c91c12fbad0.tar.xz
python/*: Moved a lot of Python stuff here
The criteria for whether something "belongs" in Development or Libraries or Python or ... is admittedly arbitrary. As a general rule, if it could be either Libraries or Python, it's Python. Otherwise, pick one and we'll go from there... Signed-off-by: Robby Workman <rworkman@slackbuilds.org>
Diffstat (limited to 'libraries/pyOpenSSL')
-rw-r--r--libraries/pyOpenSSL/README4
-rw-r--r--libraries/pyOpenSSL/pyOpenSSL.SlackBuild74
-rw-r--r--libraries/pyOpenSSL/pyOpenSSL.info10
-rw-r--r--libraries/pyOpenSSL/slack-desc19
4 files changed, 0 insertions, 107 deletions
diff --git a/libraries/pyOpenSSL/README b/libraries/pyOpenSSL/README
deleted file mode 100644
index 70e1a0d8260a..000000000000
--- a/libraries/pyOpenSSL/README
+++ /dev/null
@@ -1,4 +0,0 @@
-Python wrapper around a small subset of the OpenSSL library. Includes:
-X509 Certificates, SSL Context objects, SSL Connection objects using
-Python sockets as transport layer. The Connection object wraps all the
-socket methods and can therefore be used in.
diff --git a/libraries/pyOpenSSL/pyOpenSSL.SlackBuild b/libraries/pyOpenSSL/pyOpenSSL.SlackBuild
deleted file mode 100644
index a74c278316ce..000000000000
--- a/libraries/pyOpenSSL/pyOpenSSL.SlackBuild
+++ /dev/null
@@ -1,74 +0,0 @@
-#!/bin/sh
-
-# Slackware build script for pyOpenSSL.
-#
-# Copyright 2010-2011 Marco Bonetti <sid77@slackware.it>
-# All rights reserved.
-#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
-PRGNAM=pyOpenSSL
-VERSION=0.10
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i486 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-CWD=$(pwd)
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-DOCS="COPYING PKG-INFO README"
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
-cd $PRGNAM-$VERSION
-
-chown -R root:root .
-find . \
- \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
- -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \;
-
-python setup.py install --root=$PKG
-
-find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a $DOCS $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/libraries/pyOpenSSL/pyOpenSSL.info b/libraries/pyOpenSSL/pyOpenSSL.info
deleted file mode 100644
index 1d1be8f057b6..000000000000
--- a/libraries/pyOpenSSL/pyOpenSSL.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="pyOpenSSL"
-VERSION="0.10"
-HOMEPAGE="http://pypi.python.org/pypi/pyOpenSSL"
-DOWNLOAD="http://pypi.python.org/packages/source/p/pyOpenSSL/pyOpenSSL-0.10.tar.gz"
-MD5SUM="34db8056ec53ce80c7f5fc58bee9f093"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-MAINTAINER="Marco Bonetti"
-EMAIL="sid77@slackware.it"
-APPROVED="Erik Hanson"
diff --git a/libraries/pyOpenSSL/slack-desc b/libraries/pyOpenSSL/slack-desc
deleted file mode 100644
index 02f8c98f7632..000000000000
--- a/libraries/pyOpenSSL/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description. Line
-# up the first '|' above the ':' following the base package name, and the '|'
-# on the right side marks the last column you can put a character in. You must
-# make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':'.
-
- |-----handy-ruler------------------------------------------------------|
-pyOpenSSL: pyOpenSSL (Python wrapper for OpenSSL)
-pyOpenSSL:
-pyOpenSSL: This module is a rather thin wrapper around (a subset of) the OpenSSL
-pyOpenSSL: library. With thin wrapper I mean that a lot of the object methods do
-pyOpenSSL: nothing more than calling a corresponding function in the OpenSSL
-pyOpenSSL: library
-pyOpenSSL:
-pyOpenSSL:
-pyOpenSSL:
-pyOpenSSL:
-pyOpenSSL: