aboutsummaryrefslogtreecommitdiff
path: root/libraries/irrlicht/correct-install.diff
diff options
context:
space:
mode:
authorLarry Halali <larryhaja[at]gmail[dot]com>2010-12-22 09:24:00 -0200
committerNiels Horn <niels.horn@slackbuilds.org>2010-12-22 09:24:00 -0200
commit42e0bbbeda1f83edc685ddb692b7dac39bcf2968 (patch)
tree14213f07517ed8900bd332f3eb57e21d89f0d89a /libraries/irrlicht/correct-install.diff
parent3e2428b92106b6c4e29acbf510923f4a815bc973 (diff)
libraries/irrlicht: Added (realtime 3D engine)
Signed-off-by: Niels Horn <niels.horn@slackbuilds.org>
Diffstat (limited to 'libraries/irrlicht/correct-install.diff')
-rw-r--r--libraries/irrlicht/correct-install.diff37
1 files changed, 37 insertions, 0 deletions
diff --git a/libraries/irrlicht/correct-install.diff b/libraries/irrlicht/correct-install.diff
new file mode 100644
index 000000000000..f945dc2c1165
--- /dev/null
+++ b/libraries/irrlicht/correct-install.diff
@@ -0,0 +1,37 @@
+From: Christoph Egger <Christoph.Egger@gmx.de>
+Subject: [PATCH] debian/correct-install
+
+The variables setup for the install target does not work. We're correcting it here
+
+Signed-off-by: Christoph Egger <Christoph.Egger@gmx.de>
+
+---
+ source/Irrlicht/Makefile | 13 +++++++++++--
+ 1 files changed, 11 insertions(+), 2 deletions(-)
+
+diff --git a/source/Irrlicht/Makefile b/source/Irrlicht/Makefile
+index 49f990d..a66980b 100644
+--- a/source/Irrlicht/Makefile
++++ b/source/Irrlicht/Makefile
+@@ -141,8 +141,17 @@ install install_osx:
+ mkdir -p $(INSTALL_DIR)/../include/irrlicht
+ cp ../../include/*.h $(INSTALL_DIR)/../include/irrlicht/
+ cp $(LIB_PATH)/$(SHARED_LIB).$(VERSION) $(INSTALL_DIR)
+- cd $(INSTALL_DIR) && ln -s -f $(SHARED_LIB).$(VERSION) $(SHARED_LIB)
+-# ldconfig -n $(INSTALL_DIR)
++ cp $(LIB_PATH)/$(STATIC_LIB) $(INSTALL_DIR)
++ cd $(INSTALL_DIR) && ln -s -f libIrrlicht.so.$(VERSION) $(SHARED_LIB)
++ #ldconfig -n $(INSTALL_DIR)
++
++install_osx:
++ $(RM) -r $(INSTALL_DIR)/../include/irrlicht
++ mkdir -p $(INSTALL_DIR)/../include/irrlicht
++ cp ../../include/*.h $(INSTALL_DIR)/../include/irrlicht
++ cp $(LIB_PATH)/$(SHARED_LIB).$(VERSION) $(INSTALL_DIR)
++ cd $(INSTALL_DIR) && ln -s libIrrlicht.dylib.$(VERSION) $(SHARED_LIB)
++ ldconfig -n $(INSTALL_DIR)
+
+ TAGS:
+ ctags *.cpp ../../include/*.h *.h
+--
+tg: (9f40966..) debian/correct-install (depends on: master)