aboutsummaryrefslogtreecommitdiff
path: root/libraries/gsm/gsm.SlackBuild
diff options
context:
space:
mode:
authorTim Dickson <dickson.tim@googlemail.com>2022-08-06 00:01:35 +0100
committerWilly Sudiarto Raharjo <willysr@slackbuilds.org>2022-08-06 20:16:10 +0700
commit4af02a9cac817bcb3b37794535cd21b1ea2cb341 (patch)
treecdb4a20377797ce380b0ccd606a5b6f79e89aaa0 /libraries/gsm/gsm.SlackBuild
parent5d98b1d584308bf7e766a0975f39ee23bc24a555 (diff)
downloadslackbuilds-4af02a9cac817bcb3b37794535cd21b1ea2cb341.tar.xz
libraries/gsm: Updated for version 1.0.22.
Signed-off-by: Dave Woodfall <dave@slackbuilds.org> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'libraries/gsm/gsm.SlackBuild')
-rw-r--r--libraries/gsm/gsm.SlackBuild26
1 files changed, 12 insertions, 14 deletions
diff --git a/libraries/gsm/gsm.SlackBuild b/libraries/gsm/gsm.SlackBuild
index b09b22879036..fd369edbbfcc 100644
--- a/libraries/gsm/gsm.SlackBuild
+++ b/libraries/gsm/gsm.SlackBuild
@@ -32,11 +32,11 @@
#note to self: update patching to sed or similar for next release.
# 20220722 tim dickson: got rm patched added upstream. combined larger patch
# into easier to maintain patch, and a few sed commands.
-
+# 20220904 tim dickson: version bump to 1.0.22 (1.0-pl21). updated patch file.
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=gsm
-VERSION=${VERSION:-1.0.20}
+VERSION=${VERSION:-1.0.22}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -89,18 +89,17 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
-exec chmod 644 {} \+
-#the following patches are required but won't be fixed upstream due
+#the following patch and seds's are required but won't be fixed upstream due
#to the fact that the library supports ancient 16bit processors
-#and he doesn't have all the hardware to test with any more.
-#"shared" patch (modified from a gentoo patch).
+#and the developer doesn't have all the hardware to test with any more.
+#"shared" patch (modified and updated from a gentoo patch).
+#the Makefile patch allowd for static and shared libs.
patch < $CWD/Makefile.patch
-#next shouldn't be needed as config.h defines it (in inc/config.h)
-#patch -p1 < $CWD/patches/gsm-1.0.12-memcpy.patch
-#third patch has been replaced with a couple of sed's
+#these sed's fix 64bit compiling (but will break 16bit compiling)
+#which is only relevant for DOS, so is ok here.
sed -i 's/typedef long/typedef int/g' inc/private.h
sed -i 's/typedef unsigned long/typedef unsigned int/g' inc/private.h
-
mkdir -p $PKG/usr/bin
mkdir -p $PKG/usr/lib$LIBDIRSUFFIX
mkdir -p $PKG/usr/include/{gsm,libgsm}
@@ -115,20 +114,19 @@ make -j1 install \
GSM_INSTALL_INC=$PKG/usr/include/gsm \
GSM_INSTALL_MAN=$PKG/usr/man/man3 \
TOAST_INSTALL_MAN=$PKG/usr/man/man1
-
cp -p lib/libgsm.so.$VERSION $PKG/usr/lib$LIBDIRSUFFIX
( cd $PKG/usr/lib$LIBDIRSUFFIX
ln -s libgsm.so.$VERSION libgsm.so.1
ln -s libgsm.so.$VERSION libgsm.so
) || exit 1
-
# some apps look for this in /usr/include
( cd $PKG/usr/include/libgsm ; ln -s ../gsm/gsm.h gsm.h ) || exit 1
-# Replace hardlinks with softlinks
+# Replace fullpath links with relative links,
+# so autocreated doinst.sh is not broken
( cd $PKG/usr/bin
- rm -f toast ; ln -s tcat toast
- rm -f untoast ; ln -s tcat untoast
+ rm -f tcat; ln -s toast tcat
+ rm -f untoast; ln -s toast untoast
)
find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \