aboutsummaryrefslogtreecommitdiff
path: root/libraries/ZConfig
diff options
context:
space:
mode:
authorArn0 <yth@ythogtha.org>2023-07-05 17:17:02 +0200
committerWilly Sudiarto Raharjo <willysr@slackbuilds.org>2023-07-06 11:23:36 +0700
commitce55eb18bdbc8081ea4946395603fbdef6d51681 (patch)
treef0de8b2f4e720cf8aa21939ce3bee9cf2055bdd2 /libraries/ZConfig
parent1ec397de1b027c47ac9b296efe5e8d526c207f35 (diff)
libraries/ZConfig: replaced by python3-ZConfig
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'libraries/ZConfig')
-rw-r--r--libraries/ZConfig/README3
-rw-r--r--libraries/ZConfig/ZConfig.SlackBuild78
-rw-r--r--libraries/ZConfig/ZConfig.info10
-rw-r--r--libraries/ZConfig/slack-desc19
4 files changed, 0 insertions, 110 deletions
diff --git a/libraries/ZConfig/README b/libraries/ZConfig/README
deleted file mode 100644
index 1f572ceab9f7f..0000000000000
--- a/libraries/ZConfig/README
+++ /dev/null
@@ -1,3 +0,0 @@
-ZConfig supports a hierarchical schema-driven configuration model
-that allows a schema to specify data conversion routines written in
-Python.
diff --git a/libraries/ZConfig/ZConfig.SlackBuild b/libraries/ZConfig/ZConfig.SlackBuild
deleted file mode 100644
index 6c968a888df6f..0000000000000
--- a/libraries/ZConfig/ZConfig.SlackBuild
+++ /dev/null
@@ -1,78 +0,0 @@
-#!/bin/bash
-
-# Slackware build script for ZConfig
-
-# Copyright 2013 Mikko Värri, Finland
-# All rights reserved.
-#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
-cd $(dirname $0) ; CWD=$(pwd)
-
-PRGNAM=ZConfig
-VERSION=${VERSION:-3.0.4}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-PKGTYPE=${PKGTYPE:-tgz}
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i586 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
-if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
- echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
- exit 0
-fi
-
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $PRGNAM-$VERSION
-tar xzvf $CWD/$PRGNAM-$VERSION.tar.gz
-cd $PRGNAM-$VERSION
-chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
- -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \;
-
-python setup.py install --root=$PKG
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a LICENSE.txt COPYRIGHT.txt README.txt $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/libraries/ZConfig/ZConfig.info b/libraries/ZConfig/ZConfig.info
deleted file mode 100644
index 4e0dafee00fb7..0000000000000
--- a/libraries/ZConfig/ZConfig.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="ZConfig"
-VERSION="3.0.4"
-HOMEPAGE="https://pypi.python.org/pypi/ZConfig"
-DOWNLOAD="https://pypi.python.org/packages/source/Z/ZConfig/ZConfig-3.0.4.tar.gz"
-MD5SUM="32018f77d37f220b6a80aaf311fea63f"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES=""
-MAINTAINER="Mikko Värri"
-EMAIL="vmj@linuxbox.fi"
diff --git a/libraries/ZConfig/slack-desc b/libraries/ZConfig/slack-desc
deleted file mode 100644
index 8d9b2831e579f..0000000000000
--- a/libraries/ZConfig/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-ZConfig: ZConfig (Structured Configuration Library)
-ZConfig:
-ZConfig: ZConfig supports a hierarchical schema-driven configuration model
-ZConfig: that allows a schema to specify data conversion routines written in
-ZConfig: Python.
-ZConfig:
-ZConfig:
-ZConfig:
-ZConfig:
-ZConfig:
-ZConfig: