aboutsummaryrefslogtreecommitdiff
path: root/graphics
diff options
context:
space:
mode:
authorChristoph Willing <chris.willing@linux.com>2023-08-29 12:28:32 +1000
committerWilly Sudiarto Raharjo <willysr@slackbuilds.org>2023-09-02 18:02:41 +0700
commit3b5cc06c850586026d6f2a2dcb0837831fca4ae4 (patch)
tree03876edec205a9d57abef1bf53df8feb6e956082 /graphics
parent4ca828c688b506bb618c3b4bf9fd4d55014eaf90 (diff)
graphics/OpenSubdiv: Updated for version 3.5.1
Signed-off-by: Christoph Willing <chris.willing@linux.com> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'graphics')
-rw-r--r--graphics/OpenSubdiv/CUDA-compatibility.patch10
-rw-r--r--graphics/OpenSubdiv/OpenSubdiv.SlackBuild4
-rw-r--r--graphics/OpenSubdiv/OpenSubdiv.info6
-rw-r--r--graphics/OpenSubdiv/README1
4 files changed, 11 insertions, 10 deletions
diff --git a/graphics/OpenSubdiv/CUDA-compatibility.patch b/graphics/OpenSubdiv/CUDA-compatibility.patch
index c1cf2981e2ea..2db18f641362 100644
--- a/graphics/OpenSubdiv/CUDA-compatibility.patch
+++ b/graphics/OpenSubdiv/CUDA-compatibility.patch
@@ -1,17 +1,17 @@
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -590,8 +590,14 @@ if(CUDA_FOUND)
+--- CMakeLists.txt.orig 2023-08-29 11:13:57.755000000 +1000
++++ CMakeLists.txt 2023-08-29 11:19:42.759000000 +1000
+@@ -605,8 +605,14 @@
if (NOT DEFINED OSD_CUDA_NVCC_FLAGS)
if (CUDA_VERSION_MAJOR LESS 6)
set( OSD_CUDA_NVCC_FLAGS --gpu-architecture compute_11 )
-- else()
+- elseif (CUDA_VERSION_MAJOR LESS 8)
+ elseif (CUDA_VERSION_MAJOR LESS 9)
set( OSD_CUDA_NVCC_FLAGS --gpu-architecture compute_20 )
+ elseif (CUDA_VERSION_MAJOR LESS 11)
+ set( OSD_CUDA_NVCC_FLAGS --gpu-architecture compute_30 )
+ elseif (CUDA_VERSION_MAJOR LESS 12)
+ set( OSD_CUDA_NVCC_FLAGS --gpu-architecture compute_35 )
-+ else()
++ else ()
+ set( OSD_CUDA_NVCC_FLAGS --gpu-architecture compute_50 )
endif()
endif()
diff --git a/graphics/OpenSubdiv/OpenSubdiv.SlackBuild b/graphics/OpenSubdiv/OpenSubdiv.SlackBuild
index 3c11bac9d4ce..2af659c74b8a 100644
--- a/graphics/OpenSubdiv/OpenSubdiv.SlackBuild
+++ b/graphics/OpenSubdiv/OpenSubdiv.SlackBuild
@@ -30,7 +30,7 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=OpenSubdiv
-VERSION=${VERSION:-3.5.0}
+VERSION=${VERSION:-3.5.1}
SRCVER=$(echo $VERSION | tr . _)
BUILD=${BUILD:-3}
TAG=${TAG:-_SBo}
@@ -75,7 +75,7 @@ rm -rf $PRGNAM-$SRCVER
tar xvf $CWD/$PRGNAM-$SRCVER.tar.gz
cd $PRGNAM-$SRCVER
sed -i -e '/${OPENGL_gl_LIBRARY}/a${OPENGL_glx_LIBRARY}' CMakeLists.txt
-patch -p1 < $CWD/CUDA-compatibility.patch
+patch -p0 < $CWD/CUDA-compatibility.patch
chown -R root:root .
find -L . \
diff --git a/graphics/OpenSubdiv/OpenSubdiv.info b/graphics/OpenSubdiv/OpenSubdiv.info
index b2f9892a6bbb..79fdf9a8baaf 100644
--- a/graphics/OpenSubdiv/OpenSubdiv.info
+++ b/graphics/OpenSubdiv/OpenSubdiv.info
@@ -1,8 +1,8 @@
PRGNAM="OpenSubdiv"
-VERSION="3.5.0"
+VERSION="3.5.1"
HOMEPAGE="http://graphics.pixar.com/opensubdiv"
-DOWNLOAD="https://github.com/PixarAnimationStudios/OpenSubdiv/archive/v3_5_0/OpenSubdiv-3_5_0.tar.gz"
-MD5SUM="230f5cd2911d6240e58a3773b9c6e5e4"
+DOWNLOAD="https://github.com/PixarAnimationStudios/OpenSubdiv/archive/v3_5_1/OpenSubdiv-3_5_1.tar.gz"
+MD5SUM="15a2e1df83463116a37309156e138e43"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES=""
diff --git a/graphics/OpenSubdiv/README b/graphics/OpenSubdiv/README
index 18ad40a90098..3e64c556ac6c 100644
--- a/graphics/OpenSubdiv/README
+++ b/graphics/OpenSubdiv/README
@@ -13,4 +13,5 @@ the cudatoolkit at SBo. Therefore CUDA backend support is not enabled
by default in this SlackBuild. It must be explicitly enabled (as well
as cudatoolkit being installed) to use it in the build e.g.
ENABLE_CUDA=yes bash OpenSubdiv.SlackBuild
+N.B. Building with CUDA is currently unsupported (broken) - don't use!