aboutsummaryrefslogtreecommitdiff
path: root/games
diff options
context:
space:
mode:
authorB. Watson <urchlay@slackware.uk>2023-07-14 05:13:05 -0400
committerWilly Sudiarto Raharjo <willysr@slackbuilds.org>2023-07-15 17:30:15 +0700
commita332bbf89e7486ad5bd3a9cf6fd2bb2e99b6aad6 (patch)
tree3b3f15f9a36ded29ce73f8739506ec70f33edd78 /games
parent5b001b8fe4ed78591d249517beae69b44dcf8293 (diff)
downloadslackbuilds-a332bbf89e7486ad5bd3a9cf6fd2bb2e99b6aad6.tar.xz
games/srb2: Updated for version 2.2.11.
Signed-off-by: B. Watson <urchlay@slackware.uk> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'games')
-rw-r--r--games/srb2/doinst.sh7
-rw-r--r--games/srb2/srb2.SlackBuild27
-rw-r--r--games/srb2/srb2.info12
3 files changed, 37 insertions, 9 deletions
diff --git a/games/srb2/doinst.sh b/games/srb2/doinst.sh
index 696d35bad7e6..65c7e2eeb9aa 100644
--- a/games/srb2/doinst.sh
+++ b/games/srb2/doinst.sh
@@ -1,4 +1,9 @@
-
if [ -x /usr/bin/update-desktop-database ]; then
/usr/bin/update-desktop-database -q usr/share/applications >/dev/null 2>&1
fi
+
+if [ -e usr/share/icons/hicolor/icon-theme.cache ]; then
+ if [ -x /usr/bin/gtk-update-icon-cache ]; then
+ /usr/bin/gtk-update-icon-cache -f usr/share/icons/hicolor >/dev/null 2>&1
+ fi
+fi
diff --git a/games/srb2/srb2.SlackBuild b/games/srb2/srb2.SlackBuild
index 4d9d59d75487..526ac57f9a36 100644
--- a/games/srb2/srb2.SlackBuild
+++ b/games/srb2/srb2.SlackBuild
@@ -6,10 +6,15 @@
# Licensed under the WTFPL. See http://www.wtfpl.net/txt/copying/ for details.
+# 20230714 bkw: updated for v2.2.11.
+# - new deps (see .info file).
+# - cmake sed stuff to allow building without net access.
+# - new-style icons.
+
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=srb2
-VERSION=${VERSION:-2.2.10}
+VERSION=${VERSION:-2.2.11}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -91,6 +96,12 @@ find -L . -perm /111 -a \! -perm 755 -a -exec chmod 755 {} \+ -o \
sed -i 's,usr/games,usr/share/games,g' \
src/sdl/i_system.c src/sdl/i_ttf.c
+# 20230714 bkw: cmake silliness. it wants to download Ccache.cmake to
+# support ccache on Linux. on Windows, it seems to support ccache
+# without external dependency... and it turns out, this support works
+# on Linux as well. So:
+sed -i '/CMAKE_HOST_SYSTEM_NAME/s,STREQ.*,MATCHES Linux),' CMakeLists.txt
+
mkdir -p build
cd build
cmake \
@@ -99,6 +110,7 @@ cd build
-DCMAKE_INSTALL_PREFIX=/usr \
-DLIB_SUFFIX=${LIBDIRSUFFIX} \
-DMAN_INSTALL_DIR=/usr/man \
+ -DUSE_CCACHE=ON \
-DCMAKE_BUILD_TYPE=Release ..
make VERBOSE=1
#make install/strip DESTDIR=$PKG # don't bother, it's broken
@@ -109,11 +121,22 @@ mkdir -p $PKG/usr/games $PKG/usr/share/games/SRB2 \
$PKG/usr/share/pixmaps $PKG/usr/share/applications \
$PKG/usr/doc/$PRGNAM-$VERSION
# as of 2.2.8 the binary's name changed.
+# 20230714 bkw: ...and it changed again in 2.2.11.
+[ -x build/bin/lsdl$PRGNAM-$VERSION ] || mv build/bin/lsdl$PRGNAM build/bin/lsdl$PRGNAM-$VERSION
install -s -m0755 build/bin/lsdl$PRGNAM-$VERSION $PKG/usr/games
ln -s lsdl$PRGNAM-$VERSION $PKG/usr/games/lsdl$PRGNAM
ln -s lsdl$PRGNAM-$VERSION $PKG/usr/games/$PRGNAM
install -m0644 assets/LICENSE* assets/README* $PKG/usr/doc/$PRGNAM-$VERSION
-install -m0644 $PRGNAM.png $PKG/usr/share/pixmaps
+
+hicolor=$PKG/usr/share/icons/hicolor
+for px in 16 22 32 48 64 128 256; do
+ sz=${px}x${px}
+ dir=$hicolor/$sz/apps
+ mkdir -p $dir
+ convert -resize $sz $PRGNAM.png $dir/$PRGNAM.png
+done
+
+ln -s ../icons/hicolor/48x48/apps/$PRGNAM.png $PKG/usr/share/pixmaps/$PRGNAM.png
echo -n "Copying data files: "
( cd assets/installer
diff --git a/games/srb2/srb2.info b/games/srb2/srb2.info
index ed0286396c1a..4fc21718b3de 100644
--- a/games/srb2/srb2.info
+++ b/games/srb2/srb2.info
@@ -1,12 +1,12 @@
PRGNAM="srb2"
-VERSION="2.2.10"
+VERSION="2.2.11"
HOMEPAGE="https://www.srb2.org/"
-DOWNLOAD="https://github.com/STJr/SRB2/archive/SRB2_release_2.2.10/SRB2-SRB2_release_2.2.10.tar.gz \
- https://github.com/STJr/SRB2/releases/download/SRB2_release_2.2.10/SRB2-v2210-Full.zip"
-MD5SUM="02feaf4480b8205a05aa2c14293f242a \
- 92c68194d6e48eb7314d60f0318309b9"
+DOWNLOAD="https://github.com/STJr/SRB2/archive/SRB2_release_2.2.11/SRB2-SRB2_release_2.2.11.tar.gz \
+ https://github.com/STJr/SRB2/releases/download/SRB2_release_2.2.11/SRB2-v2211-Full.zip"
+MD5SUM="bcb3493b8668dadd8f9bfb10d3325fd6 \
+ d356b7e3db4520355b142b39c51cc8a8"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
-REQUIRES=""
+REQUIRES="libgme libopenmpt"
MAINTAINER="B. Watson"
EMAIL="urchlay@slackware.uk"