aboutsummaryrefslogtreecommitdiff
path: root/development
diff options
context:
space:
mode:
authorisaackwy <isaacyu@protonmail.com>2024-11-03 13:01:37 -0800
committerWilly Sudiarto Raharjo <willysr@slackbuilds.org>2024-11-05 00:37:10 +0700
commitfe97de4c3e13a5914a57e9d0b322dcad7718319f (patch)
tree31c0bb863941ef9eb334cc3879aeed83a0f7fea2 /development
parent93097b1b97a29fbad5ce1ff5bb36071bcba64cd8 (diff)
development/jupyter-notebook: Update for 7.0.8
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'development')
-rw-r--r--development/jupyter-notebook/jupyter-notebook.SlackBuild11
-rw-r--r--development/jupyter-notebook/jupyter-notebook.info8
2 files changed, 12 insertions, 7 deletions
diff --git a/development/jupyter-notebook/jupyter-notebook.SlackBuild b/development/jupyter-notebook/jupyter-notebook.SlackBuild
index 0f1922221e83..15b582e9f228 100644
--- a/development/jupyter-notebook/jupyter-notebook.SlackBuild
+++ b/development/jupyter-notebook/jupyter-notebook.SlackBuild
@@ -26,7 +26,7 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=jupyter-notebook
-VERSION=${VERSION:-6.5.7}
+VERSION=${VERSION:-7.0.8}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -65,13 +65,18 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python3 setup.py install --root=$PKG
+# jupyter-notebook should not ask for more dependencies
+python3 -m build --no-isolation --skip-dependency-check
+python3 -m installer -d "$PKG" dist/*.whl
+
+# Fix /etc/jupyter path
+mv $PKG/{usr/,}etc
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a CHANGELOG.md CONTRIBUTING.rst LICENSE README.md $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a CHANGELOG.md CONTRIBUTING.md LICENSE README.md $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install
diff --git a/development/jupyter-notebook/jupyter-notebook.info b/development/jupyter-notebook/jupyter-notebook.info
index 9608cabc60cf..67d9deeb4adb 100644
--- a/development/jupyter-notebook/jupyter-notebook.info
+++ b/development/jupyter-notebook/jupyter-notebook.info
@@ -1,10 +1,10 @@
PRGNAM="jupyter-notebook"
-VERSION="6.5.7"
+VERSION="7.0.8"
HOMEPAGE="https://jupyter.org/"
-DOWNLOAD="https://files.pythonhosted.org/packages/source/n/notebook/notebook-6.5.7.tar.gz"
-MD5SUM="4026bb5c1f7d517affa1e45ad6c576a2"
+DOWNLOAD="https://files.pythonhosted.org/packages/source/n/notebook/notebook-7.0.8.tar.gz"
+MD5SUM="2871e598409cc880d1bc129901b50a1b"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
-REQUIRES="jupyter-ipykernel jupyter-nbclassic python3-ipython_genutils"
+REQUIRES="jupyterlab"
MAINTAINER="Isaac Yu"
EMAIL="isaacyu@protonmail.com"