aboutsummaryrefslogtreecommitdiff
path: root/development/spyder/spyder.SlackBuild
diff options
context:
space:
mode:
authorisaackwy <isaacyu@protonmail.com>2023-12-30 12:23:26 -0800
committerWilly Sudiarto Raharjo <willysr@slackbuilds.org>2023-12-31 18:44:58 +0700
commit145895333bf028f4b16ecf10fe4b010c3f77a4ec (patch)
tree173db0d254bcbcd8657c77b258c580218f76b815 /development/spyder/spyder.SlackBuild
parent17f9c0035f3db9dc67f617aac63a6b89174e0dd2 (diff)
development/spyder: Update for 5.4.0 (+new maintainer)
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'development/spyder/spyder.SlackBuild')
-rw-r--r--development/spyder/spyder.SlackBuild17
1 files changed, 11 insertions, 6 deletions
diff --git a/development/spyder/spyder.SlackBuild b/development/spyder/spyder.SlackBuild
index d5e41ee226fd..f0e583790aa2 100644
--- a/development/spyder/spyder.SlackBuild
+++ b/development/spyder/spyder.SlackBuild
@@ -3,6 +3,7 @@
# Slackware build script for spyder
# Copyright 2010-2016 Larry Hajali <larryhaja[at]gmail[dot]com>
+# Copyright 2024 Isaac Yu <isaacyu@protonmail.com>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -25,8 +26,8 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=spyder
-VERSION=${VERSION:-5.3.1}
-BUILD=${BUILD:-2}
+VERSION=${VERSION:-5.4.0}
+BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -87,13 +88,17 @@ done
# Allow SlackBuilds python libraries versions
sed 's|IPYTHON_REQVER = ">=7.31.1;<8.0.0"|IPYTHON_REQVER = ">=7.31.1"|' -i spyder/dependencies.py
+sed "s|JEDI_REQVER = '>=0.17.2;<0.19.0'|JEDI_REQVER = '>=0.17.2'|" -i spyder/dependencies.py
+sed "s|PYLINT_REQVER = '>=2.5.0;<3.0'|PYLINT_REQVER = '>=2.5.0'|" -i spyder/dependencies.py
sed "s|QDARKSTYLE_REQVER = '>=3.0.2;<3.1.0'|QDARKSTYLE_REQVER = '>=3.0.2'|" -i spyder/dependencies.py
-sed "s|QTCONSOLE_REQVER = '>=5.3.0;<5.4.0'|QTCONSOLE_REQVER = '>=5.3.0'|" -i spyder/dependencies.py
-sed "s|SPYDER_KERNELS_REQVER = '>=2.3.1;<2.4.0'|SPYDER_KERNELS_REQVER = '>=2.3.1'|" -i spyder/dependencies.py
+sed "s|QTCONSOLE_REQVER = '>=5.4.0;<5.5.0'|QTCONSOLE_REQVER = '>=5.4.0'|" -i spyder/dependencies.py
+sed "s|SPYDER_KERNELS_REQVER = '>=2.4.0;<2.5.0'|SPYDER_KERNELS_REQVER = '>=2.4.0'|" -i spyder/dependencies.py
sed "s|ipython>=7.31.1,<8.0.0|ipython>=7.31.1|" -i setup.py
+sed "s|jedi>=0.17.2,<0.19.0|jedi>=0.17.2|" -i setup.py
+sed "s|pylint>=2.5.0,<3.0|pylint>=2.5.0|" -i setup.py
sed "s|qdarkstyle>=3.0.2,<3.1.0|qdarkstyle>=3.0.2|" -i setup.py
-sed "s|qtconsole>=5.3.0,<5.4.0|qtconsole>=5.3.0|" -i setup.py
-sed "s|spyder-kernels>=2.3.1,<2.4.0|spyder-kernels>=2.3.1|" -i setup.py
+sed "s|qtconsole>=5.4.0,<5.5.0|qtconsole>=5.5.0|" -i setup.py
+sed "s|spyder-kernels>=2.4.0,<2.5.0|spyder-kernels>=2.4.0|" -i setup.py
python3 setup.py install --root=$PKG