aboutsummaryrefslogtreecommitdiff
path: root/development/hgsvn
diff options
context:
space:
mode:
authorJoão Felipe Santos <joao.eel[at]gmail.com>2010-05-12 23:28:43 +0200
committerRobby Workman <rworkman@slackbuilds.org>2010-05-12 23:28:43 +0200
commit84f772951d1cd6adeff7b0676b746387ee8bff1a (patch)
treeb486c74c714a6abca595a3689f47cd2ac41a7a1e /development/hgsvn
parent45ed02c7656a1cf2c5a08145f9a6020efb69f33b (diff)
development/hgsvn: Added to 12.2 repository
Diffstat (limited to 'development/hgsvn')
-rw-r--r--development/hgsvn/README4
-rw-r--r--development/hgsvn/hgsvn.SlackBuild72
-rw-r--r--development/hgsvn/hgsvn.info7
-rw-r--r--development/hgsvn/slack-desc17
4 files changed, 100 insertions, 0 deletions
diff --git a/development/hgsvn/README b/development/hgsvn/README
new file mode 100644
index 000000000000..26122ee82abf
--- /dev/null
+++ b/development/hgsvn/README
@@ -0,0 +1,4 @@
+This set of scripts allows to work locally on Subversion-managed projects
+using the Mercurial distributed version control system.
+
+Requires pysetuptools and subversion-bindings, available at SlackBuilds.org
diff --git a/development/hgsvn/hgsvn.SlackBuild b/development/hgsvn/hgsvn.SlackBuild
new file mode 100644
index 000000000000..126f5e3b1ec9
--- /dev/null
+++ b/development/hgsvn/hgsvn.SlackBuild
@@ -0,0 +1,72 @@
+#!/bin/sh
+
+# Slackware build script for hgsvn
+
+# Written by João Felipe Santos (joao.eel@gmail.com)
+
+# Copyright (c) 2009 João Felipe Santos
+
+# Permission is hereby granted, free of charge, to any person obtaining a copy
+# of this software and associated documentation files (the "Software"), to deal
+# in the Software without restriction, including without limitation the rights
+# to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
+# copies of the Software, and to permit persons to whom the Software is
+# furnished to do so, subject to the following conditions:
+
+# The above copyright notice and this permission notice shall be included in
+# all copies or substantial portions of the Software.
+
+# THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+# IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+# FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
+# AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
+# LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
+# OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN
+# THE SOFTWARE.
+
+PRGNAM=hgsvn
+VERSION=${VERSION:-0.1.6}
+ARCH=${ARCH:-i486}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find . \
+ \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
+
+python setup.py build
+python setup.py install --root $PKG
+
+mkdir $PKG/usr/man
+cp -a man1 $PKG/usr/man/
+
+( cd $PKG/usr/man
+ find . -type f -exec gzip -9 {} \;
+ for i in $( find . -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
+)
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a AUTHORS.txt COPYING.txt README.txt $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.tgz
diff --git a/development/hgsvn/hgsvn.info b/development/hgsvn/hgsvn.info
new file mode 100644
index 000000000000..e9dd64a96dfc
--- /dev/null
+++ b/development/hgsvn/hgsvn.info
@@ -0,0 +1,7 @@
+PRGNAM="hgsvn"
+VERSION="0.1.6"
+HOMEPAGE="http://pypi.python.org/pypi/hgsvn"
+DOWNLOAD="http://pypi.python.org/packages/source/h/hgsvn/hgsvn-0.1.6.tar.gz"
+MD5SUM="717f21210fb84e7538d76a95a582a647"
+MAINTAINER="João Felipe Santos"
+EMAIL="joao.eel[at]gmail.com"
diff --git a/development/hgsvn/slack-desc b/development/hgsvn/slack-desc
new file mode 100644
index 000000000000..93d80cdfd57f
--- /dev/null
+++ b/development/hgsvn/slack-desc
@@ -0,0 +1,17 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description. Line
+# up the first '|' above the ':' following the base package name, and the '|' on
+# the right side marks the last column you can put a character in. You must make
+# exactly 11 lines for the formatting to be correct. It's also customary to
+# leave one space after the ':'.
+
+ |-----handy-ruler------------------------------------------------------|
+hgsvn: hgsvn (Scripts to work on Subversion checkouts using Mercurial)
+hgsvn:
+hgsvn: This set of scripts allows to work locally on Subversion-managed
+hgsvn: projects using the Mercurial distributed version control system.
+hgsvn:
+hgsvn:
+hgsvn: Homepage: http://pypi.python.org/pypi/hgsvn
+hgsvn:
+hgsvn: