aboutsummaryrefslogtreecommitdiff
path: root/desktop
diff options
context:
space:
mode:
authorMatteo Bernardini <ponce@slackbuilds.org>2024-05-14 23:04:00 +0200
committerWilly Sudiarto Raharjo <willysr@slackbuilds.org>2024-05-18 06:55:48 +0700
commitb31e104a92e47ef15154e261ec9f2db12fe5db95 (patch)
treea32c56f4b40b3ca2ff549fb7e2e002d2ab6fb73a /desktop
parent9c914427efccafa4057dd0be380c6f5bb17879d6 (diff)
downloadslackbuilds-b31e104a92e47ef15154e261ec9f2db12fe5db95.tar.xz
desktop/lxpanel: Updated for version 20230918_633a2d4.
Signed-off-by: Matteo Bernardini <ponce@slackbuilds.org> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'desktop')
-rw-r--r--desktop/lxpanel/lxpanel.SlackBuild15
-rw-r--r--desktop/lxpanel/lxpanel.info6
-rw-r--r--desktop/lxpanel/patches/lxpanel-0.10.1-fix-pager-panel-width.patch37
3 files changed, 45 insertions, 13 deletions
diff --git a/desktop/lxpanel/lxpanel.SlackBuild b/desktop/lxpanel/lxpanel.SlackBuild
index 853f3ce20f..2e16ffb833 100644
--- a/desktop/lxpanel/lxpanel.SlackBuild
+++ b/desktop/lxpanel/lxpanel.SlackBuild
@@ -28,8 +28,8 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=lxpanel
-VERSION=${VERSION:-0.10.1}
-BUILD=${BUILD:-2}
+VERSION=${VERSION:-20230918_633a2d4}
+BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -83,14 +83,9 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-if [ "$GTK3" = "yes" ]; then
- # Disable pager plugin as it breaks panel layout with GTK+ 3
- # https://sourceforge.net/p/lxde/bugs/773/
- sed -i '/pager.c/d' plugins/Makefile.am
- sed -i '/STATIC_PAGER/d' src/private.h
- sed -i 's/libwnck-3.0//' configure.ac
- autoreconf -fi
-fi
+for i in $CWD/patches/* ; do patch -p1 < $i ; done
+
+./autogen.sh || true
CFLAGS="$SLKCFLAGS" \
CXXFLAGS="$SLKCFLAGS" \
diff --git a/desktop/lxpanel/lxpanel.info b/desktop/lxpanel/lxpanel.info
index acb7f1aa94..5dc89ae13f 100644
--- a/desktop/lxpanel/lxpanel.info
+++ b/desktop/lxpanel/lxpanel.info
@@ -1,8 +1,8 @@
PRGNAM="lxpanel"
-VERSION="0.10.1"
+VERSION="20230918_633a2d4"
HOMEPAGE="https://wiki.lxde.org/en/LXPanel"
-DOWNLOAD="https://downloads.sf.net/lxde/lxpanel-0.10.1.tar.xz"
-MD5SUM="c922d044789c3d7ae028f0e80dea18b0"
+DOWNLOAD="https://ponce.cc/slackware/sources/repo/lxde/lxpanel-20230918_633a2d4.tar.xz"
+MD5SUM="e8b042e60c977c70eda52caf0f61b6b7"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES="libfm"
diff --git a/desktop/lxpanel/patches/lxpanel-0.10.1-fix-pager-panel-width.patch b/desktop/lxpanel/patches/lxpanel-0.10.1-fix-pager-panel-width.patch
new file mode 100644
index 0000000000..4d53fc8f78
--- /dev/null
+++ b/desktop/lxpanel/patches/lxpanel-0.10.1-fix-pager-panel-width.patch
@@ -0,0 +1,37 @@
+From b46e3a39786a5be04bf9cc3844dd184308cd7495 Mon Sep 17 00:00:00 2001
+From: Ben Walsh <b@wumpster.com>
+Date: Sat, 6 Jun 2020 10:38:15 +0100
+Subject: [PATCH] Specify GTK_REQUEST_CONSTANT_SIZE. Fixes #773.
+
+---
+ src/panel.c | 7 +++++++
+ 1 file changed, 7 insertions(+)
+
+diff --git a/src/panel.c b/src/panel.c
+index da9e718b..b52fc796 100644
+--- a/src/panel.c
++++ b/src/panel.c
+@@ -293,6 +293,12 @@ lxpanel_get_preferred_height (GtkWidget *widget,
+ if (natural_height)
+ *natural_height = requisition.height;
+ }
++
++static GtkSizeRequestMode
++lxpanel_get_request_mode (GtkWidget *widget)
++{
++ return GTK_SIZE_REQUEST_CONSTANT_SIZE;
++}
+ #endif
+
+ static void lxpanel_size_allocate(GtkWidget *widget, GtkAllocation *a)
+@@ -413,6 +419,7 @@ static void lxpanel_class_init(PanelToplevelClass *klass)
+ #if GTK_CHECK_VERSION(3, 0, 0)
+ widget_class->get_preferred_width = lxpanel_get_preferred_width;
+ widget_class->get_preferred_height = lxpanel_get_preferred_height;
++ widget_class->get_request_mode = lxpanel_get_request_mode;
+ #else
+ widget_class->size_request = lxpanel_size_request;
+ #endif
+--
+2.27.0
+