aboutsummaryrefslogtreecommitdiff
path: root/desktop/calcure
diff options
context:
space:
mode:
authorTonus <tonus1@gmail.com>2024-07-09 17:39:12 +0200
committerWilly Sudiarto Raharjo <willysr@slackbuilds.org>2024-07-10 19:50:10 +0700
commit21f1e1e0e7e6332f85bf5b92a6c9238834a78f1f (patch)
tree6bb4b6a622c8fd3b6f333e47da762bf520e214d5 /desktop/calcure
parentf9e48504b60b2cc34e686e18605318140678e342 (diff)
desktop/calcure: Updated for version 3.0.2
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'desktop/calcure')
-rw-r--r--desktop/calcure/calcure.SlackBuild32
-rw-r--r--desktop/calcure/calcure.info6
2 files changed, 13 insertions, 25 deletions
diff --git a/desktop/calcure/calcure.SlackBuild b/desktop/calcure/calcure.SlackBuild
index 9ea72f05138d..684610960ed7 100644
--- a/desktop/calcure/calcure.SlackBuild
+++ b/desktop/calcure/calcure.SlackBuild
@@ -25,18 +25,12 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=calcure
-VERSION=${VERSION:-3.0.1}
+VERSION=${VERSION:-3.0.2}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i586 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
+ARCH=noarch
# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
# the name of the created package would be, and then exit. This information
@@ -50,20 +44,6 @@ TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
-if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-O2 -march=i586 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
set -e
rm -rf $PKG
@@ -81,6 +61,14 @@ find -L . \
python3 setup.py install --root=$PKG
+#mv $PKG/usr/share/man $PKG/usr/man
+#gzip -9 -c $PKG/usr/man/man1/$PRGNAM.1 > $PKG/usr/man/man1/$PRGNAM.1.gz
+mkdir -p $PKG/usr/man/man1/
+gzip -9 -c $PRGNAM.1.gz > $PKG/usr/man/man1/$PRGNAM.1.gz
+rm -fR $PKG/usr/share/man
+find $PKG/usr/man -type f -exec gzip -9 {} \;
+for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
+
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
diff --git a/desktop/calcure/calcure.info b/desktop/calcure/calcure.info
index 4294556d615c..2b365d6528f3 100644
--- a/desktop/calcure/calcure.info
+++ b/desktop/calcure/calcure.info
@@ -1,8 +1,8 @@
PRGNAM="calcure"
-VERSION="3.0.1"
+VERSION="3.0.2"
HOMEPAGE="https://anufrievroman.gitbook.io/calcure"
-DOWNLOAD="https://files.pythonhosted.org/packages/26/ad/8e57777943f0075ccd6dc7f0f0d475fd30d93a7751ace2acfbfabb7c86b4/calcure-3.0.1.tar.gz"
-MD5SUM="3334daba811c9790ecce2e79dc27946f"
+DOWNLOAD="https://files.pythonhosted.org/packages/26/97/09a6ab51c4f1d9ece72eb0f9d088006f3b056b80fd5f9d9507de228eb05b/calcure-3.0.2.tar.gz"
+MD5SUM="9be4f15e745a06fc40e20ae16d7d59f0"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES="holidays jdatetime ics python3-icalendar python3-dateutil kitchen taskw pytz"