aboutsummaryrefslogtreecommitdiff
path: root/desktop/cairo-clock/patches
diff options
context:
space:
mode:
authorSébastien Ballet <slacker6896@gmail.com>2018-10-27 00:17:55 +0100
committerDavid Spencer <idlemoor@slackbuilds.org>2018-10-27 00:17:55 +0100
commit9427c6b28d3fa44b7fd5598d9a4ecb790eccb453 (patch)
tree43149955ffe42415f0aa14f1641e2fa6bee6b039 /desktop/cairo-clock/patches
parentb4ca915a374a080eaaa763557286ba38f9a439d8 (diff)
desktop/cairo-clock: Added (Analog Clock).
Signed-off-by: David Spencer <idlemoor@slackbuilds.org>
Diffstat (limited to 'desktop/cairo-clock/patches')
-rw-r--r--desktop/cairo-clock/patches/cairo-clock-check-refresh-rate-fix.patch13
-rw-r--r--desktop/cairo-clock/patches/cairo-clock-composited.patch19
-rw-r--r--desktop/cairo-clock/patches/cairo-clock-desktop-categories.patch8
-rw-r--r--desktop/cairo-clock/patches/cairo-clock-fix-build-04_624922.patch11
-rw-r--r--desktop/cairo-clock/patches/cairo-clock-fix-man-dir.patch11
5 files changed, 62 insertions, 0 deletions
diff --git a/desktop/cairo-clock/patches/cairo-clock-check-refresh-rate-fix.patch b/desktop/cairo-clock/patches/cairo-clock-check-refresh-rate-fix.patch
new file mode 100644
index 000000000000..a23663ab64d0
--- /dev/null
+++ b/desktop/cairo-clock/patches/cairo-clock-check-refresh-rate-fix.patch
@@ -0,0 +1,13 @@
+--- src/cairo-clock.c.orig 2018-04-07 10:47:48.240014958 +0200
++++ src/cairo-clock.c 2018-04-07 10:48:12.998016063 +0200
+@@ -1423,8 +1423,8 @@
+ g_iDefaultY >= gdk_screen_get_height (gdk_screen_get_default ()))
+ g_iDefaultY = 0;
+
+- if (g_iRefreshRate <= MIN_REFRESH_RATE ||
+- g_iRefreshRate >= MAX_REFRESH_RATE)
++ if (g_iRefreshRate < MIN_REFRESH_RATE ||
++ g_iRefreshRate > MAX_REFRESH_RATE)
+ g_iRefreshRate = 30;
+ }
+ else
diff --git a/desktop/cairo-clock/patches/cairo-clock-composited.patch b/desktop/cairo-clock/patches/cairo-clock-composited.patch
new file mode 100644
index 000000000000..87ebef182afe
--- /dev/null
+++ b/desktop/cairo-clock/patches/cairo-clock-composited.patch
@@ -0,0 +1,19 @@
+--- ./src/cairo-clock.c.orig 2007-08-20 06:22:45.000000000 +0200
++++ ./src/cairo-clock.c 2007-10-14 18:53:47.000000000 +0200
+@@ -1455,11 +1455,16 @@
+
+ if (!gdk_screen_is_composited (gtk_widget_get_screen (g_pMainWindow)))
+ {
++ printf( "You are not running under a composited desktop-environment (e.g. compiz).\n" );
++ printf( "cairo-clock cannot work properly without one.\n" );
++ /*
++
+ gtk_window_set_icon_from_file (GTK_WINDOW (g_pErrorDialog),
+ get_icon_filename (),
+ NULL);
+ gtk_dialog_run (GTK_DIALOG (g_pErrorDialog));
+ exit (2);
++ */
+ }
+
+ g_pPopUpMenu = glade_xml_get_widget (pGladeXml,
diff --git a/desktop/cairo-clock/patches/cairo-clock-desktop-categories.patch b/desktop/cairo-clock/patches/cairo-clock-desktop-categories.patch
new file mode 100644
index 000000000000..7737b87c9af0
--- /dev/null
+++ b/desktop/cairo-clock/patches/cairo-clock-desktop-categories.patch
@@ -0,0 +1,8 @@
+--- ./desktop/cairo-clock.desktop.orig 2007-08-20 06:22:45.000000000 +0200
++++ ./desktop/cairo-clock.desktop 2007-10-14 08:35:55.000000000 +0200
+@@ -37,4 +37,4 @@
+ Comment[zh_TW]=一個超好用的類比時鐘
+ Exec=cairo-clock
+ Icon=cairo-clock
+-Categories=GNOME;Application;Utility;
++Categories=Utility;Clock;
diff --git a/desktop/cairo-clock/patches/cairo-clock-fix-build-04_624922.patch b/desktop/cairo-clock/patches/cairo-clock-fix-build-04_624922.patch
new file mode 100644
index 000000000000..1743b806fe8b
--- /dev/null
+++ b/desktop/cairo-clock/patches/cairo-clock-fix-build-04_624922.patch
@@ -0,0 +1,11 @@
+--- ./src/Makefile.in.orig 2008-02-27 11:33:47.000000000 +0000
++++ ./src/Makefile.in 2011-08-21 09:46:30.000000000 +0000
+@@ -226,7 +226,7 @@
+ target_alias = @target_alias@
+ top_builddir = @top_builddir@
+ top_srcdir = @top_srcdir@
+-cairo_clock_LDFLAGS = -Wl, --export-dynamic
++cairo_clock_LDFLAGS = -rdynamic
+ cairo_clock_LDADD = \
+ $(GLIB_LIBS) \
+ $(GTK_LIBS) \
diff --git a/desktop/cairo-clock/patches/cairo-clock-fix-man-dir.patch b/desktop/cairo-clock/patches/cairo-clock-fix-man-dir.patch
new file mode 100644
index 000000000000..75dfc727c523
--- /dev/null
+++ b/desktop/cairo-clock/patches/cairo-clock-fix-man-dir.patch
@@ -0,0 +1,11 @@
+--- man/Makefile.in.orig 2018-02-13 11:54:07.989470517 +0100
++++ man/Makefile.in 2018-02-13 11:56:07.907475868 +0100
+@@ -209,7 +209,7 @@
+ target_alias = @target_alias@
+ top_builddir = @top_builddir@
+ top_srcdir = @top_srcdir@
+-manualdir = $(datadir)/man/man1
++manualdir = $(prefix)/man/man1
+ manual_DATA = cairo-clock.1.gz
+ EXTRA_DIST = $(manual_DATA)
+ all: all-am