aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArn0 <yth@ythogtha.org>2023-07-04 14:18:16 +0200
committerWilly Sudiarto Raharjo <willysr@slackbuilds.org>2023-07-06 11:23:31 +0700
commitfe7408a3f96e94599a7ceeb08f229bcd68708918 (patch)
tree2631b7beea2ecf9f1d1944181c157a6ce96a9aee
parented7c7cc87ddc03737cc5f913d77c64e3a43ce77a (diff)
downloadslackbuilds-fe7408a3f96e94599a7ceeb08f229bcd68708918.tar.xz
python/foolscap: Removed: obsolete, outdated, unmaintained, not working, or not needed anymore.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--python/foolscap/README5
-rw-r--r--python/foolscap/foolscap.SlackBuild99
-rw-r--r--python/foolscap/foolscap.info10
-rw-r--r--python/foolscap/slack-desc19
4 files changed, 0 insertions, 133 deletions
diff --git a/python/foolscap/README b/python/foolscap/README
deleted file mode 100644
index 694eb6cb3b6d..000000000000
--- a/python/foolscap/README
+++ /dev/null
@@ -1,5 +0,0 @@
-"Foolscap" is an RPC protocol for Python+Twisted, providing a
-capability-based security model and flexible serialization. It
-is intended to replace Twisted's native "Perspective Broker"
-RPC system. Foolscap has been under development (on and off)
-by Brian Warner for several years.
diff --git a/python/foolscap/foolscap.SlackBuild b/python/foolscap/foolscap.SlackBuild
deleted file mode 100644
index f4b0bdcea3b3..000000000000
--- a/python/foolscap/foolscap.SlackBuild
+++ /dev/null
@@ -1,99 +0,0 @@
-#!/bin/bash
-
-# Slackware build script for foolscap
-
-# Copyright 2010-2011 Marco Bonetti <sid77@slackware.it>
-# Copyright 2012-2018 Markus Reichelt, Aachen, DE
-# All rights reserved.
-#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-#
-# Originally written by Marco Bonetti - Thanks!
-# Now maintained by Markus Reichelt <slackbuilds@mareichelt.de>, 0xCCEEF115
-
-cd $(dirname $0) ; CWD=$(pwd)
-
-PRGNAM=foolscap
-VERSION=${VERSION:-0.13.1}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-PKGTYPE=${PKGTYPE:-tgz}
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i586 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
-if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
- echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
- exit 0
-fi
-
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-O2 -march=i586 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/"$PRGNAM"_"$VERSION.orig.tar.gz"
-cd $PRGNAM-$VERSION
-chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-
-python2 setup.py install --root=$PKG
-
-find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a ChangeLog* NEWS LICENSE README doc/* $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/python/foolscap/foolscap.info b/python/foolscap/foolscap.info
deleted file mode 100644
index 457770cf8266..000000000000
--- a/python/foolscap/foolscap.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="foolscap"
-VERSION="0.13.1"
-HOMEPAGE="https://pypi.org/project/foolscap/"
-DOWNLOAD="http://deb.debian.org/debian/pool/main/f/foolscap/foolscap_0.13.1.orig.tar.gz"
-MD5SUM="5eaa9a3b0e1944b09358e7b192b6dd05"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES="python2-twisted pyOpenSSL txtorcon txi2p"
-MAINTAINER="Markus Reichelt"
-EMAIL="slackbuilds@mareichelt.de"
diff --git a/python/foolscap/slack-desc b/python/foolscap/slack-desc
deleted file mode 100644
index 54d440dd010a..000000000000
--- a/python/foolscap/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-foolscap: foolscap (RPC protocol for Python+Twisted)
-foolscap:
-foolscap: Foolscap is an RPC protocol for Python+Twisted, providing a
-foolscap: capability-based security model and flexible serialization. It is
-foolscap: intended to replace Twisted's native "Perspective Broker" RPC
-foolscap: system.
-foolscap:
-foolscap: Homepage: https://pypi.org/project/foolscap/
-foolscap:
-foolscap:
-foolscap: