aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorisaackwy <isaacyu@protonmail.com>2024-06-02 18:15:44 -0700
committerWilly Sudiarto Raharjo <willysr@slackbuilds.org>2024-06-04 09:04:30 +0700
commitf97f365433293ae2ee7cf106fbf6e8a55239cd7a (patch)
tree72dc7f384c049dca3cf197a3e982199f998f35ce
parent550280dfd328aa27aaf5d568ff2f8bcbb0dc4523 (diff)
python/python3-rtree: Update for 1.2.0
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--python/python3-rtree/python3-rtree.SlackBuild28
-rw-r--r--python/python3-rtree/python3-rtree.info10
2 files changed, 15 insertions, 23 deletions
diff --git a/python/python3-rtree/python3-rtree.SlackBuild b/python/python3-rtree/python3-rtree.SlackBuild
index f07810e02fb2b..7a022c47a22a3 100644
--- a/python/python3-rtree/python3-rtree.SlackBuild
+++ b/python/python3-rtree/python3-rtree.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for python3-rtree
-# Copyright 2023 Isaac Yu <isaacyu@protonmail.com>
+# Copyright 2023-2024 Isaac Yu <isaacyu@protonmail.com>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -25,7 +25,7 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=python3-rtree
-VERSION=${VERSION:-1.0.1}
+VERSION=${VERSION:-1.2.0}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -49,20 +49,6 @@ TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
-if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-O2 -march=i586 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
set -e
rm -rf $PKG
@@ -78,13 +64,19 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python3 setup.py install --root=$PKG
+PYVER=$(python3 -c 'import sys; print("%d.%d" % sys.version_info[:2])')
+export PYTHONPATH=/opt/python$PYVER/site-packages/
+
+# python3-rtree can be built by running setup.py directly.
+# However, this brings about a "SetuptoolsDeprecationWarning: setup.py install is deprecated."
+python3 -m build --no-isolation
+python3 -m installer -d "$PKG" dist/*.whl
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a CREDITS.txt LICENSE.txt README.md $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a CREDITS.txt README.md $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install
diff --git a/python/python3-rtree/python3-rtree.info b/python/python3-rtree/python3-rtree.info
index 9a0030ace5f73..627c31e0f5768 100644
--- a/python/python3-rtree/python3-rtree.info
+++ b/python/python3-rtree/python3-rtree.info
@@ -1,10 +1,10 @@
PRGNAM="python3-rtree"
-VERSION="1.0.1"
-HOMEPAGE="https://github.com/Toblerity/rtree/"
-DOWNLOAD="https://github.com/Toblerity/rtree/archive/1.0.1/rtree-1.0.1.tar.gz"
-MD5SUM="c70d72aa1cfa232aac945735da364e9d"
+VERSION="1.2.0"
+HOMEPAGE="https://rtree.readthedocs.io/en/latest/"
+DOWNLOAD="https://github.com/Toblerity/rtree/archive/1.2.0/rtree-1.2.0.tar.gz"
+MD5SUM="8e8f8cff48ff3684907f174e695601fd"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
-REQUIRES="libspatialindex python3-wheel"
+REQUIRES="libspatialindex python3-setuptools-opt"
MAINTAINER="Isaac Yu"
EMAIL="isaacyu@protonmail.com"