aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorB. Watson <urchlay@slackware.uk>2024-10-26 00:42:36 -0400
committerWilly Sudiarto Raharjo <willysr@slackbuilds.org>2024-11-02 19:28:44 +0700
commitf2a11df3ecd9dcfa488cb223864e7fd3a836340c (patch)
tree2f018948dd9abc6e91a7cec6b33e5673851d9942
parent274852f8e91bf2e8c7855c86f209479a686ad560 (diff)
office/xournalpp: Build w/lua 5.4, fix .desktop.
Signed-off-by: B. Watson <urchlay@slackware.uk> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--office/xournalpp/xournalpp.SlackBuild24
-rw-r--r--office/xournalpp/xournalpp.info2
2 files changed, 15 insertions, 11 deletions
diff --git a/office/xournalpp/xournalpp.SlackBuild b/office/xournalpp/xournalpp.SlackBuild
index 0a020119fbd2..672fc09cc7d4 100644
--- a/office/xournalpp/xournalpp.SlackBuild
+++ b/office/xournalpp/xournalpp.SlackBuild
@@ -22,11 +22,15 @@
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+# 20241026 bkw: Modified by SlackBuilds.org, BUILD=2:
+# - update for lua 5.4.
+# - make .desktop file validate.
+
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=xournalpp
VERSION=${VERSION:-1.2.4}
-BUILD=${BUILD:-1}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -38,9 +42,6 @@ if [ -z "$ARCH" ]; then
esac
fi
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
@@ -73,16 +74,19 @@ rm -rf $PRGNAM-$VERSION
tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
cd $PRGNAM-$VERSION
chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+find -L . -perm /111 -a \! -perm 755 -a -exec chmod 755 {} + -o \
+ \! -perm /111 -a \! -perm 644 -a -exec chmod 644 {} +
# Set the right Lua version to use, otherwise it will use an older
# version, if more than one installed.
# Thanks to fourtysixandtwo (fourtysixandtwo@sliderr.net)
-sed -i 's/^find_package(Lua/find_package(Lua 5.3/' CMakeLists.txt
+sed -i 's/^find_package(Lua/find_package(Lua 5.4/' CMakeLists.txt
+
+# 20241026 bkw: Slackware 15.0's .desktop files do not support the
+# SingleMainWindow key, so desktop-file-validate fails. On -current,
+# it's supported but unnecessary, since it's set to "false" which is
+# the default anyway.
+sed -i '/^SingleMainWindow/d' desktop/*.desktop
mkdir -p build
cd build
diff --git a/office/xournalpp/xournalpp.info b/office/xournalpp/xournalpp.info
index c760f5a70a9f..e793be4ef9d3 100644
--- a/office/xournalpp/xournalpp.info
+++ b/office/xournalpp/xournalpp.info
@@ -5,6 +5,6 @@ DOWNLOAD="https://github.com/xournalpp/xournalpp/archive/v1.2.4/xournalpp-1.2.4.
MD5SUM="ea2cee6379277543dd961fb347a93750"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
-REQUIRES="graphviz lua53 portaudio"
+REQUIRES="graphviz lua portaudio"
MAINTAINER="Cristiano Urban"
EMAIL="cristiano.urban.slack@gmail.com"