aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThibaut Notteboom <thibaut.notteboom@gmail.com>2023-11-20 09:50:13 +0700
committerWilly Sudiarto Raharjo <willysr@slackbuilds.org>2023-11-20 09:59:05 +0700
commitdf60c18245e6be1c5ac50cb0a2a8e05d0a0a30f4 (patch)
tree8c4ac5041116d4dc461cb9296ff1799c14a916c5
parent6e567cdf5e58de2665e951eb42a934bb772f3dbc (diff)
python/python-serpent: Updated for version 1.41.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--python/python-serpent/python-serpent.SlackBuild20
-rw-r--r--python/python-serpent/python-serpent.info6
2 files changed, 11 insertions, 15 deletions
diff --git a/python/python-serpent/python-serpent.SlackBuild b/python/python-serpent/python-serpent.SlackBuild
index 4a73efcd421f1..4cda931c2d5e9 100644
--- a/python/python-serpent/python-serpent.SlackBuild
+++ b/python/python-serpent/python-serpent.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for python-serpent
-# Copyright 2013-2019 Thibaut Notteboom, Paris, FRANCE
+# Copyright 2013-2023 Thibaut Notteboom, Paris, FRANCE
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -25,7 +25,7 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=python-serpent
-VERSION=${VERSION:-1.28}
+VERSION=${VERSION:-1.41}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -40,9 +40,6 @@ if [ -z "$ARCH" ]; then
esac
fi
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
@@ -61,6 +58,9 @@ elif [ "$ARCH" = "i686" ]; then
elif [ "$ARCH" = "x86_64" ]; then
SLKCFLAGS="-O2 -fPIC"
LIBDIRSUFFIX="64"
+elif [ "$ARCH" = "aarch64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
else
SLKCFLAGS="-O2"
LIBDIRSUFFIX=""
@@ -81,15 +81,11 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python setup.py install --root=$PKG
-
-# Python 3 support.
-if $(python3 -c 'import sys' 2>/dev/null); then
- python3 setup.py install --root=$PKG
-fi
+python2 setup.py install --root=$PKG
+python3 setup.py install --root=$PKG
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a LICENSE PKG-INFO README.md $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a LICENSE README.md $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install
diff --git a/python/python-serpent/python-serpent.info b/python/python-serpent/python-serpent.info
index 85e4c293e7790..db626304bcf5b 100644
--- a/python/python-serpent/python-serpent.info
+++ b/python/python-serpent/python-serpent.info
@@ -1,8 +1,8 @@
PRGNAM="python-serpent"
-VERSION="1.28"
+VERSION="1.41"
HOMEPAGE="https://github.com/irmen/Serpent/"
-DOWNLOAD="https://pypi.io/packages/source/s/serpent/serpent-1.28.tar.gz"
-MD5SUM="15ef8b67c76a6d19bac9c16731a1e62a"
+DOWNLOAD="https://pypi.io/packages/source/s/serpent/serpent-1.41.tar.gz"
+MD5SUM="c0ddaba7d2625631968bec8553ab95b1"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES=""